logo-dw

Go Back   Dreamweaver Club Forums > Hand Coders Forum > HTML and CSS
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-15-2014, 05:35 AM   #1
student101
 
Join Date: Dec 2007
Posts: 379
Question media queries not working

After viewing Creating a mobile-friendly web page with Dreamweaver CS5.5 I can't get media queries to work.

Code:
<link rel="stylesheet" href="css/style.css" type="text/css" />
http://codepen.io/dentonza/pen/ByaxBe

<link rel="stylesheet" href="css/media.css" type="text/css" />
media.css
/* CSS Document */
/* Phone */
@import url("phone.css") only screen and (max-width:320px);
/* Tablet */
@import url("tablet.css") only screen and (min-width:321px) and (max-width:768px);
/* Desktop */
@import url("desktop.css") only screen and (min-width:769px);
phone.css and tablet.css
Code:
@charset "utf-8";
#container {
	width: 100%;
	min-width: 320px; /*940px;*/
}
#top_menu_panel ul li {
	width: 100%;
	display: block;
}
#content_right {
	float: none;
	width: 100%; /*220px;*/
}
__________________
Amateurs ... Built the ark.
Professionals ... Built the Titanic.
specificity [sound like spe-sifis-ity]
student101 is offline   Reply With Quote
Old 11-15-2014, 12:24 PM   #2
student101
 
Join Date: Dec 2007
Posts: 379
Default

I'm open to suggestions on how to make these media queries work
any assistance welcomed
__________________
Amateurs ... Built the ark.
Professionals ... Built the Titanic.
specificity [sound like spe-sifis-ity]
student101 is offline   Reply With Quote
Old 11-15-2014, 02:43 PM   #3
student101
 
Join Date: Dec 2007
Posts: 379
Thumbs up resolved thanks

resolved thanks for the views
__________________
Amateurs ... Built the ark.
Professionals ... Built the Titanic.
specificity [sound like spe-sifis-ity]
student101 is offline   Reply With Quote
Old 11-15-2014, 03:43 PM   #4
d a v e
 
Join Date: Feb 2006
Location: finland
Posts: 1,684
Default

was it because you linked to the css on codepen?
d a v e is offline   Reply With Quote
Old 11-15-2014, 04:04 PM   #5
student101
 
Join Date: Dec 2007
Posts: 379
Default

Quote:
Originally Posted by d a v e View Post
was it because you linked to the css on codepen?
Sorry, updated codepen same link
All of the css was needed, I'm not sure I understand -what u asking?
__________________
Amateurs ... Built the ark.
Professionals ... Built the Titanic.
specificity [sound like spe-sifis-ity]
student101 is offline   Reply With Quote
Old 11-15-2014, 05:29 PM   #6
d a v e
 
Join Date: Feb 2006
Location: finland
Posts: 1,684
Default

you said it was resolved but didn't say what the problem was. i wondered if the problem was because it was linked to the codepen css or... ?
d a v e is offline   Reply With Quote
Old 11-15-2014, 05:36 PM   #7
student101
 
Join Date: Dec 2007
Posts: 379
Default

I wasn't too sure myself, I kept clearing cache and testing till I resolved the css queries.
based on css queries my divs weren't showing correctly as per the viewport

Quote:
I'm a little confused about the min-width and max-width.
I'd prefer that the browser not get resized less than 320px, however my css doesn't do that.
__________________
Amateurs ... Built the ark.
Professionals ... Built the Titanic.
specificity [sound like spe-sifis-ity]

Last edited by student101; 11-15-2014 at 05:39 PM..
student101 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com