logo-dw

Go Back   Dreamweaver Club Forums > Hand Coders Forum > HTML and CSS
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-24-2011, 06:32 PM   #1
WebGirly3
WebGirly3's Avatar
 
Join Date: Aug 2011
Posts: 34
Default Compatibility View Issue in IE9

The web site that I'm working on is just about ready to launch. It looks great in Firefox and in Chrome.. but then there's IE9..

On each of my rental listings, I have a photo gallery as well as links to a floor plan, maps, etc. When you click on any of these photos for the larger view, IE9 brings up an error and switches the browser to Compatibility mode.

Once it does that, the design messes up and the captions on the galleries don't work either. I've searched and searched and I cannot find any solution to this issue. It doesn't seem to do this on EVERY IE9 but it does do it on mine and on my client's computers, but not on my laptop.

I'm stuck.. does anyone have any suggestions on how to stop this?

http://www.countryclubrentalsinc.com...408/index.html
WebGirly3 is offline   Reply With Quote
Old 10-24-2011, 09:39 PM   #2
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 867
Default

My guess is line 14 you have an xml declaration. Under certain conditions relevant to a system install like Vista for example, it will trigger IE CM and also mess up your styling. On my 64 bit win 7 it works fine.
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-24-2011, 10:14 PM   #3
WebGirly3
WebGirly3's Avatar
 
Join Date: Aug 2011
Posts: 34
Default

I did have an unnecessary piece of xml coding on line 14 but even after I took that out, I am still having the issue. One other thing though, I am using Vista but seems weird to me that it would cause a problem.

Any other suggestions?
WebGirly3 is offline   Reply With Quote
Old 10-24-2011, 10:52 PM   #4
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 867
Default

lemme look...
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-24-2011, 10:53 PM   #5
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 867
Default

here's a silly question but worthwhile... Did you refresh your browser? remember the pages get cached...
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-25-2011, 12:33 AM   #6
WebGirly3
WebGirly3's Avatar
 
Join Date: Aug 2011
Posts: 34
Default

Yes, I also cleared the cache but that didn't do it. I get this error: "A problem displaying countryclubrentalsinc.com caused Internet Explorer to refresh the webpage using Compatibility View."

And then it refreshes the browser in Compatibility View and screws it all up. It's bad enough that this is an issue I'm having but my client's computer also gives this error so I have to fix it but I don't know what to do.

Thanks for trying.
WebGirly3 is offline   Reply With Quote
Old 10-25-2011, 12:52 AM   #7
WebGirly3
WebGirly3's Avatar
 
Join Date: Aug 2011
Posts: 34
Default

This makes no sense but I found this article:
http://jaredheinrichs.com/ie9-a-prob...lity-view.html

It shows that the Helvetica font is causing the issue. I removed Helvetica from the web site.. and no more compatibility issues. I can't believe this! Thanks for your help!
WebGirly3 is offline   Reply With Quote
Old 10-25-2011, 01:59 AM   #8
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 867
Default

Makes sense if it fixed it Glad you got it taken care of...
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com