logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Dreamweaver General
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-23-2011, 08:55 AM   #1
Gordon Eddey
 
Join Date: Jun 2011
Posts: 2
Default Path threads work in MAMP not on line

Hi, Hope you can help, what looks like a path issue between the index.html page and the image blocks in the 'img_links_png' folder

I am busy setting up my first site at www.eddit.co.za,
using DW3, with document relative settings
testing in MAMP, localhost:8888 and then loading via
Cyberduck to an
online Apache server.

I have loaded three folders on line, using first _name for folder then name for folder only. Both give identical results

_css and css allow the styles to load, as well as the masthead images found in:
_img_mast_gif and img_mast_gif

However, the paths in
_img_links_png and img_links_png
are fine in MAMP on localhost:8888, but are broken when the file is loaded via Cyberduck and tested on line.


Here is an example of the relevant html, from the index.html file:

<div id='FOOTERlinks'>
<ul id='LINKid'>
<li>
<a href='200_LINKSzambesi/200.html'>200</a>
<img src='img_links_png/200_88iab31zambezi.png' alt='zambezi_button' width='88' height='31' class='88iab31barMicro'> </li>
<li>
<a href='201_LINKSyellow/201.html'>201</a>
<img src='img_links_png/201_88iab31microBarYellow.png' alt='yellow_button' width='88' height='31' class='88iab31barMicro' > </li>
<li>
<a href='202_LINKSchartreuse/202.html'>202</a>
<img src='img_links_png/202_88iab31microBarChartreuse.png' alt='chartreuse_button' width='88' height='31' class='88iab31barMicro' > </li>
<li>
<a href='203_LINKSzanah/203.html'>203</a>
<img src='img_links_png/203_88iab3zanah.png' alt='zanah_button' width='88' height='31' class='88iab31barMicro'>
</li>
<li>
<a href='204_LINKSgreen/204.html'>204</a>
<img src='img_links_png/204_88iab31microBarGreen.png' alt='green_button' width='88' height='31' class='88iab31barMicro'>
</li>
<li>
<a href='205_LINKSazure/205.html'>205</a> <img src='img_links_png/205_88iab31microBarAzure.png' alt='azure_button' width='88' height='31' class='88iab31barMicro'> </li>
<li>
<a href='206_LINKScyan/206.html'>206</a>
<img src='img_links_png/206_88iab31microBarCyan.png' alt='cyan_button' width='88' height='31' class='88iab31barMicro'> </li>
<li> <a href='207_LINKSblue/207.html'>207</a>
<img src='img_links_png/207_88iab31microBarBlue.png' alt='blue_button' width='88' height='31' class='88iab31barMicro'> </li>
<li> <a href='208_LINKSpurple/208.html'>208</a>
<img src='img_links_png/208_88iab31microBarPurple.png' alt='purple_button' width='88' height='31' class='88iab31barMicro'> </li>
<li > <a href='209_LINKSrose/209.html'>209</a>
<img src='img_links_png/209_88iab31microBarRose.png' alt='rose_button' width='88' height='31' class='88iab31barMicro' ></li>
</ul>
</div><!-FOOTERlinks -->

The question is, what should the file root say in order for this to both work in MAMP and on line?

Appreciate the help.

Regards,

Gordon Eddey
Gordon Eddey is offline   Reply With Quote
Old 06-25-2011, 02:33 AM   #2
Ricky55
Ricky55's Avatar
 
Join Date: Oct 2005
Location: West Yorkshire, UK
Posts: 1,855
Default

Using MAMP shouldn't have any bearing on the paths to your images. When using MAMP BTW you are best using the standard ports of

Apache 80
mySQL 3306

Then you don't have to use :8888 you can just use local host. MAMP Pro I think is well worth purchasing as it makes setting up testing servers a very easy so you don't have to use htdocs for all your work. You can get around this with the standard version but the Pro version makes it easy.
__________________
Qwerty Design

Check out my blog for web design insights.
http://www.qwerty-design.co.uk/
Follow me on Twitter: @QwertyDesignUK
Ricky55 is offline   Reply With Quote
Old 06-25-2011, 05:52 AM   #3
Gordon Eddey
 
Join Date: Jun 2011
Posts: 2
Default

Thanks Ricky

Much appreciated.

Regards,

Gordon
Gordon Eddey is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com