logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Spry
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-04-2012, 07:56 PM   #1
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default Spry eye

Hello,

I use DW CS3. Once in a while I design a new page where I insert a series of Spry collapsible panels. When inserting, I generally choose that they are closed by default, but the display is open. When working with the collapsible panels, there's usually an eye in the right corner of the title tab - the eye is open or closed depending on whether the collapsible information is visible or not.

For some reason, today's project is behaving strangely, and I'm not able to reliably see the eye, nor to control whether the collapsible information can be hidden.

Where is this control, and why is it not acting in a consistent manner?
RainForest is offline   Reply With Quote
Old 01-04-2012, 10:31 PM   #2
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

Additional info:

I have identified a definite connection between creating a link in the content portion of the panel and the eye disappearing.

As long as I just put info in the content area, the eye remains. As soon as I make a link from a line of content, the eye goes away, and with it my ability to close the panel. It doesn't matter whether I choose the top line of content, or a line in the middle.

I have compared the code on the page that is giving me trouble with a page that is working correctly, and see no discrepancies between the two.

When I preview the page in my browser, the panels are all open and unable to close.
RainForest is offline   Reply With Quote
Old 01-05-2012, 01:00 AM   #3
DWcourse
DWcourse's Avatar
 
Join Date: Apr 2009
Posts: 3,276
Default

can you post a working and non-working page online somewhere?
__________________
If my answer helped, check out DWcourse.com for Dreamweaver tips and tutorials.
DWcourse is offline   Reply With Quote
Old 01-05-2012, 04:07 PM   #4
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

working:
http://www.cityofdepoebay.org/pages/...ive_index.html

not working:
http://www.cityofdepoebay.org/pages/...ive_index.html
RainForest is offline   Reply With Quote
Old 01-05-2012, 04:52 PM   #5
gentleone
gentleone's Avatar
 
Join Date: Nov 2009
Location: Rhodes, Greece
Posts: 2,837
Default

In code view almost at the bottom of the page you have a piece of javascript where you define which panels should be closed on page load.
On the 'working' page all the panels are set to close... hence the option {contentIsOpen:false}
HTML Code:
<script type="text/javascript">
<!--
var CollapsiblePanel1 = new Spry.Widget.CollapsiblePanel("council_2002", {contentIsOpen:false});
var CollapsiblePanel2 = new Spry.Widget.CollapsiblePanel("council_2003", {contentIsOpen:false});
var CollapsiblePanel3 = new Spry.Widget.CollapsiblePanel("council_2004", {contentIsOpen:false}); 
var CollapsiblePanel4 = new Spry.Widget.CollapsiblePanel("council_2005", {contentIsOpen:false});
var CollapsiblePanel5 = new Spry.Widget.CollapsiblePanel("council_2006", {contentIsOpen:false});
var CollapsiblePanel6 = new Spry.Widget.CollapsiblePanel("council_2007", {contentIsOpen:false});
var CollapsiblePanel7 = new Spry.Widget.CollapsiblePanel("council_2008", {contentIsOpen:false});
var CollapsiblePanel8 = new Spry.Widget.CollapsiblePanel("council_2009", {contentIsOpen:false});
var CollapsiblePanel9 = new Spry.Widget.CollapsiblePanel("council_2010", {contentIsOpen:false});
var CollapsiblePanel10 = new Spry.Widget.CollapsiblePanel("council_2011", {contentIsOpen:false});
//-->
</script>
On your 'not working' page you only have 2007 and 2008 set to close
HTML Code:
<script type="text/javascript">
<!--
var CollapsiblePanel3 = new Spry.Widget.CollapsiblePanel("council_2004"); 
var CollapsiblePanel4 = new Spry.Widget.CollapsiblePanel("council_2005");
var CollapsiblePanel5 = new Spry.Widget.CollapsiblePanel("council_2006");
var CollapsiblePanel6 = new Spry.Widget.CollapsiblePanel("council_2007", {contentIsOpen:false});
var CollapsiblePanel7 = new Spry.Widget.CollapsiblePanel("council_2008", {contentIsOpen:false});
var CollapsiblePanel8 = new Spry.Widget.CollapsiblePanel("council_2009");
//-->
</script>
__________________
www.gentlemedia.nl
gentleone is offline   Reply With Quote
Old 01-05-2012, 05:22 PM   #6
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

Great! Problem ID'd!

Now: the working page was created just last week, and I used the identical process to create the non-working page yesterday (e.g.: from the layout tab I selected Spry Collapsible Panel).

Why are the two pages not behaving the same, and what can I do to have the code behave properly without having to edit the code directly? And why do they (apparently) work until I create a link? I toyed around with that over and over and over yesterday, and could reliably reproduce the error.

Also, after editing the code on the non-working page, the design view is still incorrect (no eye appears to allow me to close the panels)

Last edited by RainForest; 01-05-2012 at 05:30 PM.. Reason: addl info
RainForest is offline   Reply With Quote
Old 01-05-2012, 07:39 PM   #7
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

Quote:
Originally Posted by RainForest View Post
When inserting, I generally choose that they are closed by default, but the display is open.
I didn't mention that something unusual is happening at this step. After naming the panel, when I click on the down arrow next to the Collapsible Panel Properties Default State, the background info in the Properties area changes, eliminating my ability to change the Display or the panel name!

However, if I insert a new collapsible panel, immediately go into the source code after choosing "Default State: Closed" and add the missing part (". {contentIsOpen:false}"), and /then/ edit the panel, the eye remains when I create data links!?!

What the heck is going on?
RainForest is offline   Reply With Quote
Old 01-05-2012, 07:53 PM   #8
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

I managed to get an error! Does this help?

Last edited by RainForest; 10-07-2014 at 04:54 PM..
RainForest is offline   Reply With Quote
Old 01-05-2012, 08:26 PM   #9
gentleone
gentleone's Avatar
 
Join Date: Nov 2009
Location: Rhodes, Greece
Posts: 2,837
Default

Quote:
Originally Posted by RainForest View Post
What the heck is going on?
Sorry... I hardly use Design View, so I can't help you with Design View issues. Perhaps someone else can help you out with that.
__________________
www.gentlemedia.nl
gentleone is offline   Reply With Quote
Old 01-05-2012, 11:19 PM   #10
RainForest
RainForest's Avatar
 
Join Date: Mar 2008
Posts: 168
Default

I have found a workaround.

Something still isn't right about the way DW is behaving, but if I do all the steps in a backwards order (choosing the properties last instead of first), the finished product displays correctly in a live document (even though design view still isn't displaying correctly).

And I guess that's all that matters.

Thanks to those who responded.
RainForest is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com