logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Web Hosting and FTP
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-04-2009, 01:43 AM   #1
opk
 
Join Date: Jul 2009
Posts: 16
Default can't view my page suddenly

Suddenly my page can't be viewed with firefox and i.e. 8, only with i.e. older versions!! All you can see is the background colour! (in i.e. 8 you can view it only in "compatibility view")

Can you view it? I tried as well with another computer and had the same results.

This is not the first site I create with DW. I created a template and then added my pages (page from template) and since yesterday I could view it everywhere!

It can't be a host problem since nothing is wrong with my other sites hosted in the same place...



What's wrong?? Any ideas??? I'm going crazy!



Thanks!!


link to my page: http://opk.php0h.com/portal/
opk is offline   Reply With Quote
Old 07-04-2009, 01:59 AM   #2
opk
 
Join Date: Jul 2009
Posts: 16
Default

update: when I hit "LIVE VIEW" again I see nothing but the background colour. Therefore I have done something wrong in DW, adjustment or script... but what???
opk is offline   Reply With Quote
Old 07-04-2009, 07:58 AM   #3
Corrosive
Corrosive's Avatar
 
Join Date: Feb 2008
Location: Bristol, England
Posts: 7,103
Default

Quote:
Originally Posted by opk View Post
update: when I hit "LIVE VIEW" again I see nothing but the background colour. Therefore I have done something wrong in DW, adjustment or script... but what???
Your closing </body> tag is in a strange place, half way through your code. Try moving it to where it should be and see if it makes a difference.
Corrosive is offline   Reply With Quote
Old 07-04-2009, 12:56 PM   #4
opk
 
Join Date: Jul 2009
Posts: 16
Default

The source code that I get when I click in my browser View|source is different from my source code index.html in DW (I' m not a code expert). And nothing seems wrong with the second. The body tag is indeed at the end of the script!

Here it is:

Quote:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><!-- InstanceBegin template="/Templates/index.dwt" codeOutsideHTMLIsLocked="false" -->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<!-- InstanceBeginEditable name="doctitle" -->
<title>index</title>
<!-- InstanceEndEditable -->
<link href="oneColElsCtr.css" rel="stylesheet" type="text/css" />
<!-- InstanceBeginEditable name="head" -->
<!-- InstanceEndEditable -->
<script src="SpryAssets/SpryMenuBar.js" type="text/javascript"></script>
<link href="SpryAssets/SpryMenuBarHorizontal.css" rel="stylesheet" type="text/css" />
<link href="SpryAssets/SpryMenuBarVertical.css" rel="stylesheet" type="text/css" />
</head>
<body class="oneColElsCtr">
<div id="container">
<div id="mainContent">
<h1>&nbsp; </h1>
<h1><!-- InstanceBeginEditable name="img" --><img src="images/backgn.jpg" alt="backg" width="764" height="618" /><!-- InstanceEndEditable --></h1>
<ul id="MenuBar1" class="MenuBarHorizontal">
<li><a href="about.html">σχετικά</a></li>
<li><a href="bio.html">βιογραφικό</a></li>
<li><a class="MenuBarItemSubmenu" href="works.html">έργο</a>
<ul>
<li><a href="paintings.html">ζωγραφική - εργασίες</a> </li>
<li><a href="posters.html">αφίσες</a></li>
<li><a href="graphics.html">γραφικές τέχνες</a></li>
<li><a href="photos.html">φωτογραφίες</a></li>
<li><a href="video.html">video</a></li>
</ul>
</li>
<li><a href="contact.html">επικοινωνία</a></li>
</ul>
<h1>&nbsp;</h1>
<!-- InstanceBeginEditable name="text" -->
<p>
<!-- end #container -->
<span class="grey">Ορέστης Π Κύρτσης</span></p>
<p class="blueletters">εικαστικές εφαρμογές + οπτική επικοινωνία</p>
<!-- InstanceEndEditable -->
<p>&nbsp; </p>
<!-- InstanceBeginEditable name="table" -->
<table width="426" height="91" border="0" class="colorborder">
<tr>
<td width="767" height="87"><p>σχετικά με τη σελίδα ...</p>
<p>&nbsp;</p></td>
</tr>
</table>
<!-- InstanceEndEditable -->
<!-- end #mainContent --></div>
<p>&nbsp;</p>
<p>&nbsp;</p>
<!-- InstanceBeginEditable name="copyright" -->
<p class="littlegrey"> opk.gr 2008</p>
<!-- InstanceEndEditable -->
<p class="littlegrey">&nbsp;</p>
<p class="littlegrey">&nbsp;</p>
<p class="littlegrey">&nbsp;</p>
<p class="littlegrey">&nbsp;</p>
</div>
<script type="text/javascript">
<!--
var MenuBar1 = new Spry.Widget.MenuBar("MenuBar1", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//-->
</script>
</body>
<!-- InstanceEnd --></html>
Thanks for helping!
opk is offline   Reply With Quote
Old 07-04-2009, 07:00 PM   #5
DWcourse
DWcourse's Avatar
 
Join Date: Apr 2009
Posts: 3,276
Default

On the live version you've got a bunch of stuff after the closing body tag (beginning with:
</noscript>

That's not in the code you posted. That's probably you're issue.
__________________
If my answer helped, check out DWcourse.com for Dreamweaver tips and tutorials.
DWcourse is offline   Reply With Quote
Old 07-05-2009, 03:22 AM   #6
opk
 
Join Date: Jul 2009
Posts: 16
Default

I do see the problem on the live version (the one that is available in the browser and you are refering to and not the DW LIVE CODE option), but have no idea how to fix it since the code I get in DW seems to be correct either in "Live Code" and actual mode.

Here is the index.html "live code" as seen in DW.

Quote:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><!-- InstanceBegin template="/Templates/index.dwt" codeOutsideHTMLIsLocked="false" --><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<!-- InstanceBeginEditable name="doctitle" -->
<title>index</title>
<!-- InstanceEndEditable -->
<link href="oneColElsCtr.css" rel="stylesheet" type="text/css">
<!-- InstanceBeginEditable name="head" -->
<!-- InstanceEndEditable -->
<script src="SpryAssets/SpryMenuBar.js" type="text/javascript"></script>
<link href="SpryAssets/SpryMenuBarHorizontal.css" rel="stylesheet" type="text/css">
<link href="SpryAssets/SpryMenuBarVertical.css" rel="stylesheet" type="text/css">
</head><body class="oneColElsCtr">
<div id="container">
<div id="mainContent">
<h1> </h1>
<h1><!-- InstanceBeginEditable name="img" --><img src="images/backgn.jpg" alt="backg" width="764" height="618"><!-- InstanceEndEditable --></h1>
<ul id="MenuBar1" class="MenuBarHorizontal">
<li><a href="about.html">σχετικά</a></li>
<li><a href="bio.html">βιογραφικό</a></li>
<li><a class="MenuBarItemSubmenu" href="works.html">έργο</a>
<ul>
<li><a href="paintings.html">ζωγραφική - εργασίες</a> </li>
<li><a href="posters.html">αφίσες</a></li>
<li><a href="graphics.html">γραφικές τέχνες</a></li>
<li><a href="photos.html">φωτογραφίες</a></li>
<li><a href="video.html">video</a></li>
</ul>
</li>
<li><a href="contact.html">επικοινωνία</a></li>
</ul>
<h1> </h1>
<!-- InstanceBeginEditable name="text" -->
<p>
<!-- end #container -->
<span class="grey">Ορέστης Π Κύρτσης</span></p>
<p class="blueletters">εικαστικές εφαρμογές + οπτική επικοινωνία</p>
<!-- InstanceEndEditable -->
<p> </p>
<!-- InstanceBeginEditable name="table" -->
<table width="426" height="91" border="0" class="colorborder">
<tbody><tr>
<td width="767" height="87"><p>σχετικά με τη σελίδα ...</p>
<p> </p></td>
</tr>
</tbody></table>
<!-- InstanceEndEditable -->
<!-- end #mainContent --></div>
<p> </p>
<p> </p>
<!-- InstanceBeginEditable name="copyright" -->
<p class="littlegrey"> opk.gr 2008</p>
<!-- InstanceEndEditable -->
<p class="littlegrey"> </p>
<p class="littlegrey"> </p>
<p class="littlegrey"> </p>
<p class="littlegrey"> </p>
</div>
<script type="text/javascript">
<!--
var MenuBar1 = new Spry.Widget.MenuBar("MenuBar1", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//-->
</script>
<!-- InstanceEnd -->
</body></html>
Or should I look for this code (the live one you 're refering to) somewhere else??

Thanks a lot!

Last edited by opk; 07-05-2009 at 03:36 AM..
opk is offline   Reply With Quote
Old 07-05-2009, 02:22 PM   #7
opk
 
Join Date: Jul 2009
Posts: 16
Default

Quote:
Originally Posted by DWcourse View Post
On the live version you've got a bunch of stuff after the closing body tag (beginning with:
</noscript>

That's not in the code you posted. That's probably you're issue.
The script in live mode is indeed the same with the one in DW up to the point of the body tag. The rest of the script is crap and I really cannot understand how it arises!!!! I can't find this part of the script nowhere in DW.

Last edited by opk; 07-05-2009 at 02:37 PM..
opk is offline   Reply With Quote
Old 07-05-2009, 02:40 PM   #8
Corrosive
Corrosive's Avatar
 
Join Date: Feb 2008
Location: Bristol, England
Posts: 7,103
Default

Quote:
Originally Posted by opk View Post
The script in live mode is indeed the same with the one in DW up to the point of the body tag. The rest of the script is crap and I really cannot understand how it arises!!!! I can't find this part of the script nowhere in DW.
It seems to be generated by some kind of pop-up advertisement. This may have been added by your hosts. Are you using free hosting?
Corrosive is offline   Reply With Quote
Old 07-05-2009, 02:57 PM   #9
opk
 
Join Date: Jul 2009
Posts: 16
Default

Hmm, probably you're right. Yes I'm using a free host for testing... The rest of the code must be pop-ups and ads, that's why is different - I hadn't thought of that (...) Therefore the problem it has nothing to do with the code itself... or something is missing in the script and causes the issue.
opk is offline   Reply With Quote
Old 07-06-2009, 06:57 PM   #10
opk
 
Join Date: Jul 2009
Posts: 16
Default

It seems there's no solution... I have to rebuilt the site from the very beginning... Hours of work lost.
opk is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com