Go Back   Dreamweaver Club Forums > Dreamweaver forums > Video Tutorials
Register FAQ Members List Search Today's Posts Mark Forums Read

Thread Tools Display Modes
Old 01-30-2009, 08:07 PM   #1
Join Date: Jan 2009
Posts: 3
Default problem connecting to the mamp db


i have followed your tutorial and its very good but i have a problem.

when i get to the part where you click add databases/mysqlconnection i get an error.

it searches for the databases on my myphpadmin but says:

http error code 404 file not found. here are some possible resons
1, there is no testing server running on the machine
2, the testing server specified for this site does not map to the url

all my pathes seem good.

the site is like this

step 1:

site name = eventtrafik

local root folder =
hard drive:Users:rickyspiresocuments:web:mamp:eventtr afik:

default image folder =
hard drive:Users:rickyspiresocuments:web:mamp:eventtr afik:wwwroot:images:

this comes up with an error saying:
WARNING: the selected folder does not contain the current sites home page. the site map can not be built.

but it does contain the index.php.
could it be because my site uses SMARTY or because the files are inside a wwwroot folder inside eventtrafik

could it be to do with permissions or htaccess ???

remote info:
hard drive:Applications:MAMP:htdocs:eventtrafik:

url prefix =

another thought....

could it be because i already have db cofig files in the wwwroot folder that show different db login usernames and passwods ??

rickyspires is offline   Reply With Quote
Old 01-30-2009, 09:43 PM   #2
davidj's Avatar
Join Date: Sep 2005
Location: The Toon (newcastle upon Tyne)
Posts: 8,256

im not sure what the problem could be as your using mamp

i use wampserver and the vids are based on that installation

try adding this to a page called info.php

PHP Code:



drop the script where you think the www root is

then browse it using http://localhost/info.php
Would you like to learn PHP from me? Check out -> www.codezenith.co.uk
davidj is offline   Reply With Quote
Old 01-31-2009, 11:54 PM   #3
Join Date: Jan 2009
Posts: 27

I had some problems using MAMP so I switched to XAMPP and had better luck. You may want to give it a shot. I know fans of each, but that was my experience and my solution.

WallyJ is offline   Reply With Quote
Old 02-02-2009, 12:53 AM   #4
edbr's Avatar
Join Date: Aug 2005
Location: Bali
Posts: 11,192

i use apache2triad
If you're happy and you know it shake your meds!
different style links examples

Flight / Hotel search
Free script download
Bali Villas
edbr is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 01:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com