logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Dreamweaver General
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-10-2006, 01:30 PM   #1
newbie
 
Join Date: May 2005
Posts: 6
Default opening a hyperlink in a frame

hi, i've a problem with opening a hyperlink in a frame.

if i make a link in frame A, and a hyperlink to file B and define with the target parameter to open file B in frame B (named B) my browsers are going to open file B in a new browserwindow.

after a lot of try and error i solved the problem, but i didn't understand the reason.

dreamweaver generates code like id="leftframe" by giving the left frame a name. and in the target i have to fill in this id (leftframe). but it doesn't work.

after i changed manually the tag id into name it works correctly and the wanted file is opened in the defined frame.

is this an error of dreamweaver or are there some options or extras not correct set in my dreamweaver installation? did anyone ever seen this problem?

thx in advance, chris.
newbie is offline   Reply With Quote
Old 04-11-2006, 01:19 PM   #2
majetta
 
Join Date: Apr 2006
Posts: 10
Default

it seems my copy of dreamweaver has a mind of its own when i try to open the frameset source page , i have toclose all open files and then rightclick on the frameset file in the files folder and select open in dreanweaver .

i tried a simple 2 frame set named _1 and _2

<frameset rows="80,*" frameborder="no" border="0" framespacing="0">
<frame src="top.html" name="_1" scrolling="No" noresize="noresize" id="topFrame" title="_top" />
<frame src="bottom.html" name="_2" id="mainFrame" title="_main" />
</frameset>

the top page has the links:

[/b]google in 1
[/b]google in 2

this seemed to work fine and opend the pages in the apropriate frames. im not aware of any frame naming scheme, but _main and _top don't work for me.
majetta is offline   Reply With Quote
Old 04-12-2006, 07:21 AM   #3
newbie
 
Join Date: May 2005
Posts: 6
Default NAME-tag and ID-tag

To Majetta:

Of course, if a frame ist named by the tag NAME it works correctly. But if any frame is autonamed by dreamweaver with the tag ID it seems not possible to open it by calling the ID in another frame.

If I've opened any frameset I can select the code in the windows "frames" by clicking in or on the borders shown in the bottom of this window. There is no problem in my installation of dreamweaver.

However, I solved my problem by using the tag NAME and changing the generated code manually and so this thread would be closed.

Have a nice day,

Chris.
newbie is offline   Reply With Quote
Old 04-12-2006, 07:24 AM   #4
newbie
 
Join Date: May 2005
Posts: 6
Default Majetta

I've forgotten to tell: _top and all other primary internal framenames of dreamweaver would work in my installation, the problem seems to belong to selfdefined framenames. They wouldn't be known by dreamweaver and so the standard action of the system is to open the framecontent in a new window.
newbie is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com