logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Dreamweaver General
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-05-2012, 12:49 PM   #11
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Question mosaic 1.0.1.js not on the local disk error

Hi All,

Thanks to everyone's help above I got my 3 boxes working correctly, so firstly thank you to everyone that helped.

I have now come to intergrate another 3 on another page and I get the mosaic 1.0.1.js not on the local disk error.

I saved the mosaic code into my web template which is the same as my working page here http://thebarkercompany.co.uk/index2.html

However this page keeps getting the error.
http://thebarkercompany.co.uk/sizing_guide/

Can anyone please see where i have gone wrong.

Thanks Alot!!
Crumpy1 is offline   Reply With Quote
Old 10-05-2012, 12:59 PM   #12
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 869
Default

Without checking it I immediately notice you are missing theese two lines:
HTML Code:
<link rel="stylesheet" href="ajximagerotator.css" type="text/css" />
<

script src="ajximagerotator.js" type="text/javascript"></script>
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-05-2012, 01:32 PM   #13
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Default

Quote:
Originally Posted by johnMoss View Post
Without checking it I immediately notice you are missing theese two lines:
HTML Code:
<link rel="stylesheet" href="ajximagerotator.css" type="text/css" />
<

script src="ajximagerotator.js" type="text/javascript"></script>
Thank you for pointing that out, i have added these now, but these files too get the not on disk error. These two files are in my root folder or htdocs but for some reason the page cannot see them, yet my index2 page which shared this directory does?

Any ideas?
Crumpy1 is offline   Reply With Quote
Old 10-05-2012, 01:40 PM   #14
domedia
Administrator
domedia's Avatar
 
Join Date: Dec 2003
Posts: 9,730
Default

Look at your page. You have 404 for all your images.
domedia is offline   Reply With Quote
Old 10-05-2012, 01:49 PM   #15
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Default

Quote:
Originally Posted by domedia View Post
Look at your page. You have 404 for all your images.
Which image are you referring to?

I have just checked one of the boxes image source http://thebarkercompany.co.uk/Assets...saic/coats.jpg and that is found ok.

If i do have any 404 errors i will fix this immediately.

The problem i am having is the loading screen constantly as the js scripts are supposedly not in the file directory but they are and their location is definitely correct.
Crumpy1 is offline   Reply With Quote
Old 10-05-2012, 02:19 PM   #16
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 869
Default

D found it, your issue is your file paths.

For example you have this as your file path for the first box:
HTML Code:
<img src="Assets/images/Mosaic/lead.jpg"/>
I can't quite see your root structure, but have a look at this & verify the path is correct.
Where is this page stored in relation to the image file?
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-05-2012, 02:28 PM   #17
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Default

Quote:
Originally Posted by johnMoss View Post
D found it, your issue is your file paths.

For example you have this as your file path for the first box:
HTML Code:
<img src="Assets/images/Mosaic/lead.jpg"/>
I can't quite see your root structure, but have a look at this & verify the path is correct.
Where is this page stored in relation to the image file?
Ok the file location folder for these images files are

htdocs/barkers/Assets/images/Mosaic/lead.jpg

The sizing guide page is called index.html and is located in another folder off the root called sizing_guide

htdocs/barkers/sizing_guide/index.html

These were the same images i used on the homepage (index2.html), i mealy copied the code from it. I have changed the images and used the browse to file option in the code to ensure the location is correct and it is.

All files are from the same folder, below is the location of 1

../Assets/images/size-ferret.jpg

I am still getting the same error.

Hope this makes sense.

Thanks for the help!

Last edited by Crumpy1; 10-05-2012 at 02:47 PM.. Reason: changed images.
Crumpy1 is offline   Reply With Quote
Old 10-05-2012, 02:49 PM   #18
johnMoss
johnMoss's Avatar
 
Join Date: Dec 2010
Location: Dallas
Posts: 869
Default

Ok, so to retrieve the image, the request has to go "up" one level to get into the assets folder. To travel up one level, you use this: "../"
So:
Code:
<img src="../Assets/images/Mosaic/lead.jpg"/>
__________________
LinkedIn: jM
johnMoss is offline   Reply With Quote
Old 10-05-2012, 02:54 PM   #19
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Default

Quote:
Originally Posted by johnMoss View Post
Ok, so to retrieve the image, the request has to go "up" one level to get into the assets folder. To travel up one level, you use this: "../"
So:
Code:
<img src="../Assets/images/Mosaic/lead.jpg"/>
my images already use the ../, I think :s

../Assets/images/dog.jpg

Can you show me how i would do this image using the go up way you mentioned above?

Also I have noticed that most of the js files are doing the same the mosaic.1.0.1.js thinks this file is in the sizing-guide folder with the page, however this part of the code is locked by my template. How can i unblock the head tag of a template?

Thanks for the patience and support!
Crumpy1 is offline   Reply With Quote
Old 10-05-2012, 02:58 PM   #20
Crumpy1
Crumpy1's Avatar
 
Join Date: Aug 2011
Location: England
Posts: 249
Default

Thanks johnMoss for the help. I added ../ to the location of my mosaic.1.0.1.js file and everything worked.

Many Many Many (x1000) Thank You's!!!!!
Crumpy1 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com