logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Spry
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-06-2010, 01:48 AM   #1
tacotac
 
Join Date: Sep 2010
Location: Beach Park, IL
Posts: 6
Default Bg color width hover off in IE

http://www.tacotac.net/ajsafety/

I adjusted the width of my ul li to auto, so all the text would show in the submenu links, but in IE the hover color does not extend to the length of the submenu box, only to the text length. In firefox no issues. Where can I fix this?
tacotac is offline   Reply With Quote
Old 10-06-2010, 02:21 AM   #2
edbr
edbr's Avatar
 
Join Date: Aug 2005
Location: Bali
Posts: 11,164
Default

looks the same in ie8 as firefox. which ie are you using?
__________________
If you're happy and you know it shake your meds!
different style links examples

Flight / Hotel search
Free script download
Bali Villas
edbr is offline   Reply With Quote
Old 10-06-2010, 02:25 AM   #3
tacotac
 
Join Date: Sep 2010
Location: Beach Park, IL
Posts: 6
Default

Mine is IE 7
tacotac is offline   Reply With Quote
Old 10-06-2010, 02:28 AM   #4
tacotac
 
Join Date: Sep 2010
Location: Beach Park, IL
Posts: 6
Default

I pasted the link for IE 8 in my IETester, but the hover color doesn't extend to the length of the submenu box either. Hmmm...
tacotac is offline   Reply With Quote
Old 10-06-2010, 02:40 AM   #5
edbr
edbr's Avatar
 
Join Date: Aug 2005
Location: Bali
Posts: 11,164
Default

setting at auto the menu will extend to the length of the text both in the ul and Li states. which to me looks like what it is doing. or am i missing something?
__________________
If you're happy and you know it shake your meds!
different style links examples

Flight / Hotel search
Free script download
Bali Villas
edbr is offline   Reply With Quote
Old 10-06-2010, 03:34 AM   #6
DWcourse
DWcourse's Avatar
 
Join Date: Apr 2009
Posts: 3,276
Default

The problem is in the submenus.

Try creating a ul.MenuBarHorizontal ul a (for links in submenus only) style rule and setting the width to 100% and see if that works.
__________________
If my answer helped, check out DWcourse.com for Dreamweaver tips and tutorials.
DWcourse is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com