logo-dw

Go Back   Dreamweaver Club Forums > Dreamweaver forums > Spry
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-19-2009, 12:19 AM   #1
Fishwagon
 
Join Date: Nov 2009
Posts: 4
Default Submitting Form on Second Panel does not post

Hello!

I have created a menu for a lunch shop. On the test page, there are two tabs, one for this weeks menu, and one for next.

On the first tab, everything works great. You add to cart, and the item gets added and you are sent to the cart page.

On the second tab, nothing happens.

The page in question submits to itself, where some PHP code collects the data from the POST and does processing to add it to the cart. Then it redirects the person to the cart page.

It use to simply go to the first tab, so I figured ah, let me send it the panel to send to, so I did that, and now I have it staying on the same panel, but it still doesn't do anything.

I ran through the PHP code, and it's winds up it's not gettign the POST data, so all my variables are blank, and nothing happens as it thinks there is nothign to add to the cart.

To see the behavior, you can go to:

http://www.teacherslunchbox.com/ourlunches2.php

So basically, the second tab is not posting it's data.

Any ideas? This is my first time trying to use a SPRY Tabbed Panel.

Thanks everyone,
Rich
Fishwagon is offline   Reply With Quote
Old 11-19-2009, 01:29 AM   #2
edbr
edbr's Avatar
 
Join Date: Aug 2005
Location: Bali
Posts: 11,175
Default

hm if you had the second tab as a seperate page ,not using spry does it work then? i would do this to elimminate spry (or not) as the reason for failiure
__________________
If you're happy and you know it shake your meds!
different style links examples

Flight / Hotel search
Free script download
Bali Villas
edbr is offline   Reply With Quote
Old 11-19-2009, 02:19 AM   #3
Fishwagon
 
Join Date: Nov 2009
Posts: 4
Default

Yes, as a matter of fact, the code on the tabbed page was lifted directly from the page that is currently in place on the operational website.

I created the tabbed interface so it has a "cleaner" look versus the currently operational page.

Also, I "swapped" the code from one tab to another and the problem stayed with the second tab. So I'm pretty convinced it's a spry problem.

One thing, I did the same thing with an accordian, and that works fine. It's only on the tabbed panels that it does not work.

This one has my hair turning gray, and with 4 kids, I don't have much left to turn gray!!
Fishwagon is offline   Reply With Quote
Old 11-19-2009, 02:48 AM   #4
edbr
edbr's Avatar
 
Join Date: Aug 2005
Location: Bali
Posts: 11,175
Default

right im not a fan of spry so ive avoided it seems a few problems come from it , maybe rather than re invent it you should try tabs using show hide functions ot a css tab design .
its a cop out answer i know but i can't beging to help on this .
anyone?
__________________
If you're happy and you know it shake your meds!
different style links examples

Flight / Hotel search
Free script download
Bali Villas
edbr is offline   Reply With Quote
Old 11-19-2009, 02:54 AM   #5
Fishwagon
 
Join Date: Nov 2009
Posts: 4
Default

Yeah, the more I work with Spry, I think it's great for basic layout functionality, but put any "real" code behind it, and it seems to be a little bit flakey.

Appreciate the help nonetheless....
Fishwagon is offline   Reply With Quote
Old 11-20-2009, 03:22 AM   #6
Fishwagon
 
Join Date: Nov 2009
Posts: 4
Default

Ok, I have to fall on my sword....

This is the dreaded ID 10 T error....

I did a find/replace the night before, and called it a night. The next day I had this issue and forgot about the previous nights find/replace.

So basically I had form items named differently than what the function expected. So when it posted from object NameA and the function was looking for the posted item from NameB, well, it didn't find it and hence didn't work.

Did I mention I feel like an idiot?

Anwyay, thanks...

Rich
Fishwagon is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com