Dreamweaver Club Forums

Dreamweaver Club Forums (http://www.dreamweaverclub.com/forum//index.php)
-   Spry (http://www.dreamweaverclub.com/forum//forumdisplay.php?f=189)
-   -   Spry hiding behind video?!? (http://www.dreamweaverclub.com/forum//showthread.php?t=42361)

wbuchina 01-04-2012 06:47 PM

Spry hiding behind video?!?
 
Hi. I have just embedded a youtube video into my site, but now the spry menu is 'hidden', for lack of a better word, behind the video.

http://williambuchina.com/africa/video.html

Any idea how to remedy this problem?

Any help is much appreciated.

Thanks
w

edbr 01-05-2012 01:09 AM

not when i checked its not

wbuchina 01-05-2012 03:37 AM

you're right! I checked it in firefox and safari and it works fine, I usually use chrome and in that, it is doing what I initially said. Any idea why that is? clearly an issue with that browser...anything I can do about it?

by the way, how is Bali? I used to live in Canggu!

Thanks
w

gentleone 01-05-2012 03:27 PM

For chrome you'll need to add ?&wmode=opaque to the end of the youtube url. So with your youtube video you'll get this:
HTML Code:

http://www.youtube.com/embed/FsOlILl2jlc?&wmode=opaque
If you have users that insert youtube vids through a CMS you can use javascript or a javascript framework such as jQuery to add it by manipulating the DOM.
HTML Code:

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>
<script>
$(document).ready(function() {
    var opaque = '&wmode=opaque';
    $('#videowrapper iframe').attr('src', function(index, attr) {
        return attr + '?' + opaque;
    });
});
</script>



All times are GMT. The time now is 12:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com