Dreamweaver Club Forums

Dreamweaver Club Forums (http://www.dreamweaverclub.com/forum//index.php)
-   HTML and CSS (http://www.dreamweaverclub.com/forum//forumdisplay.php?f=170)
-   -   Hover intent for menu items (http://www.dreamweaverclub.com/forum//showthread.php?t=42078)

WotNow 11-16-2011 05:42 AM

Hover intent for menu items
 
Hi I need some help trying to activate hover intent http://cherne.net/brian/resources/jquery.hoverIntent.html

on a menu. My aim is to have the images move up and then down when you hover over them and I am also having trouble getting them to line up behind the slides.

Here is what I have muddled with http://www.kimberleywebdesign.com.au/test/

edbr 11-16-2011 06:09 AM

Make sure you name this to your correct div names I would suggest
Code:

$(document).ready(function(){
                        $("#demo1 li").hover(makeTall,makeShort);
                        $("#demo2 li").hoverIntent(makeTall,makeShort);
                        $("#demo3 li").hoverIntent({
                                over: makeTall,
                                timeout: 500,
                                out: makeShort
                        });


WotNow 11-16-2011 08:50 AM

Hi Ed, thanks for that! I dont know javascript but it seems to be working now but not the way its supposed to. Sorry to bug you but would you mind looking at it for me, and explaining what the code does, thanks.

Also where do the little white dots in the navigation come from?

gentleone 11-16-2011 09:20 AM

Quote:

Originally Posted by WotNow (Post 201095)
Also where do the little white dots in the navigation come from?

Those are the default bullets from the list items ;) Add the property list-style-type: none on the ul in your CSS.

WotNow 11-16-2011 11:59 AM

Thanks for that gentle one, I should have known that .. I guess it threw me because they are not next to the text. This menu is doing my head in but I am determined to get it right.

When you first load the page the menu items are sitting above the slideshow and when you hover your mouse over the navigation from left to right they sort of jump and its not until you get to the contact image at the end that the slide moves into the correct position and then if you go back and hover over the home image the slideshow jumps up and down.

Thanks so much for any help.


All times are GMT. The time now is 09:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2006 DreamweaverClub.com