PDA

View Full Version : respond.min.js and boilerplate.css


dougg
01-24-2017, 07:14 PM
I'm creating a new fluid grid web page with images. When I save the html file, I'm prompted to save the respond.min.js. and boilerplate.css files also. When I do, the images no longer appear - only placeholders. What can I do to ensure my images appear on my page and still have it responsive?

edbr
01-24-2017, 07:30 PM
hard to say. check the new page code as to what the image src is

dougg
01-24-2017, 07:42 PM
thanks,
here is the src as it appears in my html:

<div id="photodiv2"><img src="../photos/Scenery/Rides/1-1/2trail2web.jpg" alt="1 1/2 test">
</div>

edbr
01-24-2017, 09:20 PM
a guess then the preceding. ../ is being added try deleting it or change to just /

dougg
01-24-2017, 10:39 PM
I tried both deleting, and just /
Neither worked.

The strange thing is that the links were working fine, until I added the boilerplate.css and response.min.js.

I'm wondering if it could be something in those files?

edbr
01-25-2017, 12:03 AM
i would suspect response.js rather than a css file unless there is a display : none directive but i cant see whay that would be there. is this live? if so give us the URL of the site

edbr
01-25-2017, 12:10 AM
in fact why not just remove the include response.min.js and see idf the images appear and i guess then try remove the link to boiler plate as a de bug test

dougg
01-25-2017, 01:14 AM
I removed both the response.js and the boilerplate.css to see what would happen.
Still no success at adding an image, until I added an image that was already being used on another page. I figured out that the "insert image" command would successfully insert the resources from one file folder, but not from the adjacent folder. So I transferred the jpegs from that folder into the one that worked, and now all jpegs are loading successfully.

I've attached a screenshot of my file path.
I can't figure out why the "insert image" function will upload a photo from one folder, but the same photo in the adjacent folder only uploads as placeholder?

Thanks for you help, I'll try putting back the response and boilerplate now.

edbr
01-25-2017, 03:01 AM
im sure its a path problem maybe folder spalling or a missed space in the name still glad you got it sorted
\

dougg
01-25-2017, 03:31 AM
Yes, it seems to be a path problem. All working now, even with boilerplate and response.min
Thanks for your help

edbr
01-25-2017, 05:00 AM
no worries