PDA

View Full Version : Magento 2 Install Error


Crumpy1
05-17-2016, 08:12 PM
Hi All,

I have just installed Magento on Xampp and i get the following error

"System messages

One or more indexers are invalid. Make sure your Magento cron job is running."

I have found a fix for this here...

http://magento.stackexchange.com/questions/92737/how-to-fix-one-or-more-indexers-are-invalid-make-sure-your-magento-cron-job-is

but i do not understand where to enter the command it refers to.

Can anyone advise how to do this?

Copy of the error https://dl.dropboxusercontent.com/u/104598901/error.jpg

Thanks.

edbr
05-18-2016, 02:12 AM
sounds like terminal time, are you using windows?

in any case this might help

http://www.magentotutorials.in/magentotutorials/magento-cron-run-window-xamp-wamp/

Crumpy1
05-19-2016, 07:19 PM
Thanks for the suggestion, I have tried this but unfortunately, it did not work.

I am using windows 10 yes btw.

Any other ideas? This issue is driving me mad :(

edbr
05-20-2016, 01:09 AM
o shame . did u try the line suggested?
to do it go to start menu > in the os search type cmd > click cmd.exe

that will open a terminal

if not selecting C:\ at start type cd C:\ > click enter

right click and paste the line (adjusted to your own directory and project name)
xampp\php>php C:\xampp\htdocs\magento2\bin\magento indexer:reindex
that is what is suggested on the link you gave so try that

edbr
05-20-2016, 01:10 AM
following there is a guide to creating a cron job on the same forum ( use the terminal)

Crumpy1
05-20-2016, 06:20 PM
My xampp install is saved at d:\xamp

My magento is saved to localhost/htdocs/PCM/store

I have changed the c: to d: in the cmd and saved the cron.bat to the localhost/php directory

i have amended the code to

d:\xampp\php>php d:\xampp\htdocs\PCM\store\bin\magento indexer:reindex

and get the following error:

The name specified is not recognized as an internal or external command, operable program or batch file.

What am i doing wrong?

edbr
05-21-2016, 03:48 AM
i think the path is wrong. refer back to your oen link for advice. i only have my phone with me and its trick to follow your link to mag forum

Crumpy1
05-21-2016, 04:16 PM
Thanks for the help, i got it working.

I replaced the d:\xampp\php>php with d:\xampp\php\php & voila, it worked.

edbr
05-22-2016, 01:09 AM
good to hear :)

Henry Roger
09-22-2016, 11:07 AM
Why don't you use the easiest way to install Magento 2? The chances of errors are minimal here. You can install it from archive file. You can download the file from https://www.magentocommerce.com/download. After downloading, you can choose any archive type.

Access the website folder like localhost/magento2 and follow the setup wizard.

For more details, visit http://www.demagento.com/how-to-install-magento-2/

edbr
09-23-2016, 06:43 AM
the poster said he had solved the issue solved it in this very old post. still a poor option in my opinion