PDA

View Full Version : Can't close gap between Banner and Menu


PauloS
02-12-2016, 06:52 PM
Hi Folks,
I'm very new to DW CS6 and new DW altogether. I understand very little about coding. But, I'm creating my own website and the home page is almost there but there is a gap between my header banner and the menu. I've been all over the web googling about this but I can't seem to solve it. I've attached a picture of a split screen view for you. I hope it's enough information for you to see the problem. (this all in DW at the moment, no URL yet exists).

I'm also including the code here:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>PE</title>
<link href="text.css" rel="stylesheet" type="text/css" />
<style type="text/css">
<!--


body {
background-color: #FFFFFF;
}
.style1 {
color: #F0F0F0
}
.style2 {
color: #993333;
font-size: 12px;
font-family: Arial, Helvetica, sans-serif;
font-weight: bold;
}
.style4 {color: #000000}
body,td,th {
font-style: italic;
}
.style2 strong {
font-style: normal;
}
.text {
font-style: normal;
}
.paragraphtitle {
font-size: 14px;
}
-->
</style></head>


body {
background-color: #FFFFFF;
}
.style1 {
color: #F0F0F0
}
.style2 {
color: #993333;
font-size: 12px;
font-family: Arial, Helvetica, sans-serif;
font-weight: bold;
}
.style4 {color: #000000}
body,td,th {
font-style: italic;
}
.style2 strong {
font-style: normal;
}
.text {
font-style: normal;
}
.paragraphtitle {
font-size: 14px;
}
-->
</style></head>

<body>
<p>&nbsp;</p>
<table width="900" border="0" align="middle" cellpadding="0" cellspacing="0">
<tr>
<td height="159" colspan="2" bordercolor="#ECE9D8" bgcolor="#000000">
<img src="images/_vti_cnf/untitled.jpg" alt="" width="1034" height="159" style="display:block;"/>

<tr bgcolor="#000000">
<td colspan="2" valign="top" bordercolor="#ECE9D8" bgcolor="#000033" ><!-- #BeginLibraryItem "/www/Library/menu.lbi" -->

edbr
02-13-2016, 02:18 AM
Im on a phone so cant see but i suspect its a border colapse issue. I have to say though if you are learning do not bother with tables for layout it really is not advisable today they belong in the past

domedia
02-13-2016, 05:25 AM
Just looking at it, you have two closing </head> tags. Remove the first one, and see if it helps.

Also from the little I can see of the <table> code, there's a <tr> inside a <td> and that's not possible. Again, not sure this is your issue, but it is an issue.