PDA

View Full Version : 404 error on 1 page only using IE9


Crumpy1
07-11-2013, 07:11 PM
Hi,

I am having a problem with 1 of my pages in Internet Explorer only. I am using 9 but i have not tested older versions.

I am getting a 404 error when the page is there, it works on firefox and chrome so i do not understand it.

the 404 error page is here http://transformyourshape.co.uk/training/MetafFit.php

my other pages work fine so i do not understand it!

I am really lost with this, and would appreciate even the smallest bit of help!

Thanks

domedia
07-11-2013, 08:04 PM
404 is a http request error, so browser should be irrelevant.

http://transformyourshape.co.uk/training/MetafFit.php
That URL above is not a page (404), in all my browsers.

Crumpy1
07-11-2013, 08:36 PM
Sorry I made a typo with the link it should have been http://transformyourshape.co.uk/training/MetaFit.php . I know that the 404 error is due to a missing file etc, but of some reason on ie9 this coming up with this error.

I have tried usin my mobile safari, Firefox & Chrome and these all work ok, Internet explorer just won't do it.


Any ideas?

Crumpy1
07-12-2013, 04:28 PM
I have spent the last 7 hours or so trawling through the web and came up with nothing, has anybody got any ideas at all on this, even if it is just a guess that I can try to see if this will work?

Thanks Guys!!

Ricky55
07-12-2013, 10:09 PM
Loads ok in IE6 but with loads of JS errors not that you should care about IE6.

Do you have an .htaccess file on your server?

If so check that this doesn't contain an error.

Do you have this line in it: ErrorDocument 404 /404.php

You might want to take a look at the htaccess that comes with the HTML5 boiler plate, that comes with quite a few error fixes.

http://www.initializr.com/

As Dom said though the browser shouldn't have any bearing on this.

Crumpy1
07-15-2013, 05:06 PM
My .htaccess file is locked by the host so I cannot open it or view it.

This error is still their and apart from redesigning the whole page again I have no idea how to fix this.

I do not understand the boilerplate thing, so would need help with this if you believe this would fix the issue.

I may have found a fix for this, I have read a post based on the same issue as me here http://stackoverflow.com/questions/5273673/http-404-error-in-internet-explorer-only

They wrote this question off as to vague but they suggested that the javascript on the page had errors and may have caused this.

I rememeber reading above from Ricky55 that my page has js errors so would like some help correcting these to see if this corrects the issue.

Thanks

Crumpy1
07-15-2013, 05:42 PM
FIXED!!!!

Do not worry about checking the issue for JavaScript errors, I just redesigned the page and the glitch has been resolved.

Thanks guys all the same for the help!

domedia
07-15-2013, 08:14 PM
I guess that is one way of fixing the problem ;-D

Crumpy1
07-16-2013, 08:00 AM
I guess that is one way of fixing the problem ;-D

Yeah, it was a one way to do it, it took about 10 mins to redo it all vs hours with you guys to fix all the javascript errors on the page before.

Either way works perfectly now :-D