PDA

View Full Version : xampp wont start!


tony09uk
06-07-2012, 10:09 PM
I have just re formatted my computer and installed xampp. After doing so APACH wont work the message is something like port[80] busy.

I don't have skye on my computer so that not the issue. I have tried to change the port by following a youtube video, but without luck.

Can someone please tell me where I can find a good tutorial to change the port or preferably how to find what program is using port 80 so I can change that or any other advice you may be able dispense

davidj
06-08-2012, 06:50 PM
It could be IIS which is using port 80 so try and stop it in services and set it to manual

or

If you open your httpd.conf and change the following...

Listen 80

to...

Listen 8080

and

ServerName localhost:80

to...

ServerName localhost:8080

then restart services

you will need to reference all local sites using the following convension

localhost/site:8080

tony09uk
06-10-2012, 08:06 PM
I followed your advice and unfortunately it didn't work. so i reinstalled xampp and made sure I checked all the boxes i.e. apache, mysql, filezilla.

After the installiation was complete i went to the control panel and the only modules that were selected were mysql and filezilla. I checked the apache box and an alert popped up saying "Click OK to install the apache server" which I did. so im now wondering if it is not installing at all?

tony09uk
06-10-2012, 09:32 PM
FINALLY!!!! after day 5 of doing this I have sorted it.

For anyone else suffering from this problem, I solved it by installing C++ 2008, it seems I had C++2005. I also found a helpful (although not for me) tutorial here (http://shavindra.wordpress.com/2011/06/20/xampp-troubleshooting-apache-wont-start/)

tony09uk
06-10-2012, 09:33 PM
david J Thanks for your advice

tony09uk
06-12-2012, 08:43 AM
Now i've got xampp running I would like it to start up when I open windows (thanks to the dawn of smart phones the only reason I come on my computer now is to code).

i have looked around and found alot of people advising that I check the SVC box next to the applicable service, which is fine and start required services when I select the xampp icon, but does not start xampp when I start up my computer. Is there an option to start xampp on starting windows, im using XP

edbr
06-12-2012, 09:12 AM
did yu look in administration local services or maybe dragon to the start folder

davidj
06-12-2012, 10:25 AM
If you look in Services you should set mysqld, httpd to automatic. The Xampp consol is only an interface which you rarely need. As long as your dev environment is working you should be ok.