PDA

View Full Version : Unusual Link issue DWCS5


alienduck
06-07-2012, 05:51 PM
I'm not a noob, nor a master, but my google-fu usually gets me through. However, this one has me stumped.

To be brief: one link works, the rest don't. check out the page

http://crowsegal.com/beta/troubleshoot.html

Spry Menu works.
Beneath the word "Header" you'll see "link" that works. below that there are several more "link". They do not work. Take a look at the code. The only thing that separates one from the other is a p tag.

I've looked through my scripts and don't see anything suspect. Perhaps another set of eyes may see something I don't.

Any suggestions are greatly appreciated.

edbr
06-08-2012, 03:19 AM
i seems to be a problem with the template, i moved the editable region tags and it works fine so i would check that all the editable regions are opend an closed and are no strays in there
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Crow Sega Management Company, Inc.</title>

<link rel="stylesheet" type="text/css" href="index.css" media="all" />
<script type="text/javascript" src="js/jquery.js"></script>
<script type="text/javascript" src="js/easySlider1.7.js"></script>
<script src="../SpryAssets/SpryMenuBar.js" type="text/javascript"></script>
<script type="text/javascript">
$(document).ready(function(){
$("#slider").easySlider({
auto: true,
continuous: true,
numeric: true
});
});
</script>

<!--[if IE]>
<style type="text/css" media="all">.borderitem {border-style: solid;}</style>
<![endif]-->
<link href="../SpryAssets/SpryMenuBarMain.css" rel="stylesheet" type="text/css" />
<style type="text/css">

</style>

<style type="text/css">
#picadmin {
margin-bottom: 25px;
text-align: left;
}
</style>

</head>

<body>
<div id="container">
<div id="main">

<div id="clickhome"><a href="index-2.html"><img src="images/spacer.gif" alt="Crow Segal Management" width="300" height="100" id="clickhome" /></a></div>

<ul id="MainNav" class="MenuBarMain
">
<li><a class="MenuBarItemSubmenu" href="about.html">About Us</a>
<ul>
<li><a href="about.html#profiles">Personel Profiles</a></li>
<li><a href="clients.html">Clients</a></li>
</ul>
</li>
<li><a href="services.html" class="MenuBarItemSubmenu">Services</a>
<ul>
<li><a href="admin.html">Administration</a></li>
<li><a href="web-pub.html">Web and Publicaiton</a></li>
<li><a href="membership.html">Membership Service</a></li>
<li><a href="staff.html">Support Staff</a></li>
<li><a href="meetings.html">Meetings Management</a></li>
</ul>
</li>
<li><a href="contact.html">Contact Us</a> </li>
</ul>
</div>


<div class="content">
<div id="leftcolumn">

<div id="picadmin"><img src="images/admin.jpg" width="220" height="283" alt="Administrative Services" /></div>
<div class="quote" id="left01">Quote e, morbi pede mori ut nulla. Quis et volutat, sed metus, id ac, fermentum vitae qui commodo molestie, augue vel metus. Metus lorem juson suscipit </div>
<div class="bubblebox" id="left02">
<p>Left middle content box Lorem ipsum dolor sit amet, mauris scelerisque pellentesque odio proin vestibulum, integer parturient sit</p>
<p> Lorem ipsum dolor sit amet, mauris scelerisque pellentesque odio proin vestibulum, integer parturient sit</p>
</div>
<div class="bubblebox" id="left03">
<p>Left bottom content box</p></div>
</div>

<div id="rightcolumn">

<h1>Header</h1>

<p><a href="http://ahpba.org"> link</a></p>

<p> <a href="http://ahpba.org"> link</a><a href="http://ahpba.org"> link</a></p>



<p><a href="http://ahpba.org"> link</a></p>

<p>Lorem ipsum dolor sit amet, mauris scelerisque pellentesque odio proin vestibulum, integer parturient sit libero vulputate orci, dolor orci vero eget qui. Bibendum aliquid vel mauris mauris nisl purus, amet vestibulum, ipsum luctus consequat volutpat magnis, a sit est <a href="http://ahpba.org"> link</a><
quis aenean. A tristique, morbi pede morbi ut nulla. Quis et volutpat, sed metus, id ac, fermentum vitae qui commodo molestie, augue vel metus. Metus lorem justo suscipit aliquam vestibulum, aliquam donec suscipit in urna pede.</p>
<p><a href="http://ahpba.org">Content for New Div Tag Goes Here</a></p>
<p> <a href="http://ahpba.org"> link</a></p>

</div>


</div>

<ul class="NavBottom">
<li id="left"><a href="index-2.html">HOME</a></li>
<li class="middle"><a href="about.html">ABOUT</a></li>
<li class="middle"><a href="clients.html">CLIENTS</a></li>
<li class="middle"><a href="services.html">SERVICES</a></li>
<li class="middle"><a href="admin.html">ADMINISTRATION</a></li>
<li class="middle"><a href="web-pub.html">PUBLICATION</a></li>
<li class="middle"><a href="membership.html">MEMBERSHIP SERVICES</a></li>
<li class="middle"><a href="staff.html">STAFF SUPPORT</a></li>
<li class="middle"><a href="meetings.html">MEETINGS MANAGEMENT</a></li>
<li id="right"><a href="contact.html">CONTACT</a></li>

</ul>

</div>
<script type="text/javascript">
var MenuBar1 = new Spry.Widget.MenuBar("MainNav", {imgDown:"../SpryAssets/SpryMenuBarDownHover.gif", imgRight:"../SpryAssets/SpryMenuBarRightHover.gif"});
</script>
</body>
</html>

alienduck
06-08-2012, 09:12 PM
The template basically sets the navigation at top and bottom with a large editable region in the middle. However, just to be sure, I copied the code an placed it into a page w/o the template.

http://crowsegal.com/beta/troubleWOedit.html

The problem persists. I've examined the styles and scripts and cannot seem to find what is causing this frustrating oddity. If there are any code masters out there who are looking for a challenge. This is it. I'd hate to have to rebuild the redesign based on this one issue, so any help is appreciated.

Lane

alienduck
06-08-2012, 09:55 PM
I've done a little more digging/tinkering. Somehow it is in the CSS. If I remove this line

<link rel="stylesheet" type="text/css" href="index.css" media="all" />

from the <head>, the styles/formatting goes away (obviously) and all of the links work.

Have I inadvertently used a bit of code that disables my links?

Anyone aware of what bit of CSS might cause links not to function?

-- Lane

alienduck
06-08-2012, 09:58 PM
oops.

link wo template

http://crowsegal.com/beta/troubleWOedits.html

edbr
06-09-2012, 02:12 AM
its this

ul.NavBottom {
position: relative;
margin-bottom: 0px;
list-style-type: none;
padding: 0px;
width: 725px;
margin-top: 50px;
margin-right: auto;
margin-left: auto;
}

if you decreace the width its fine in effect you are over laying the links so you cannot click them . example
ul.NavBottom {
position: relative;
margin-bottom: 0px;
list-style-type: none;
padding: 0px;
width: 100px;
margin-top: 50px;
margin-right: auto;
margin-left: auto;
}

alienduck
06-12-2012, 11:32 PM
Sorry to say, that changing the size did not fix the issue. The container div is 800 px wide. Should be plenty of room.

It seems that the ul at the bottom of the page isn't really at the bottom. The ul is at the top of the page just under the main navigation, which puts it at the top of the div in which it resides (container). Dreamweaver seems to be trying to show me this (if I am interpreting this correctly.)

http://crowsegal.com/beta/images/DW-screenshot.png

So the question becomes how do I get the ul to appear after (below) the other divs?