PDA

View Full Version : image link not working


Rue88
11-26-2011, 12:34 PM
Hi,

I have an image I linked to another page in my site, it works fine in IE but is not clickable on my Mac or in Google Chrome, Firefox...you can view it here: www.alkiesliquors.com (http://www.alkiesliquors.com) it is the Holiday Gift Sets Image on the home page.

Can you offer any advice?

Thanks so much,
Rue

Corrosive
11-26-2011, 12:47 PM
It is probably because your h5 tag isn't closed but using an image map seems an odd way of linking anyway. Try;

<a href="GiftSets.html"><img src="images/GiftSets.gif" alt="Holiday Gift Sets" name="HGS" width="225" height="113" border="0" align="middle" ></a>

Rue88
11-26-2011, 01:09 PM
Thanks for your reply.

I tried that code and it still doesn't work. I uploaded it so it's live, can you take a look at it? I appreciate your help.

Rue88
11-27-2011, 03:01 PM
Still need help please. Anyone?

Corrosive
11-27-2011, 03:14 PM
When I check with developer tools in Firefox (view CSS), something about your menu seems like it is about 500 pixels high and with a high z-index so it seems to be covering the image you want to link. The image is linked correctly but something else is wrong and I can't quite see what.

DWcourse
11-27-2011, 04:56 PM
Remove the bottom:0 property from the ul.MenuBarHorizontal rule.

There's no need to use a top and bottom property for the same object.

Rue88
11-27-2011, 08:36 PM
Okay, I found two spots where the z-index was over 1000. I changed those to 0 and updated everything. I also removed the bottom property on the ul.MenuBarHorizontal ul as suggested. It appears to be something to due with the Spry Menu Bar, sometimes when I make a change I get a line that appears straight down from the end of the menu bar and it locks up my design. I didn't really know why it was doing it, but it makes sense now that from the end of the menu down my page it is covering my image. I am attaching a screen shot to show you what I mean.

http://www.alkiesliquors.com/images/Line.JPG

DWcourse
11-27-2011, 08:44 PM
You shouldn't edit the default z-index settings in a Dreamweaver Spry menu.

If you take the page that you currently have online at http://www.alkiesliquors.com/ and delete the bottom:0 property as I suggested it should work.

BTW, posting an image doesn't really help. We need to be able to see the actual page live.

Rue88
11-27-2011, 09:07 PM
Oh, I deleted the bottom:0 in the ul menubarHorizontal ul but not the
ul menubarHorizontal...DUH! THANK YOU SO MUCH - I GOT IT!!! :) and Thanks for letting me know about not to post an image...I'm clearly still learning. I really, really appreciate your help. Take Care, Rue