PDA

View Full Version : Lightbox2 problems


hairybeard
11-16-2011, 06:03 PM
Hi there,
I'm designing a site in DW CS4 & want to use Lightbox2 with a number of car photos. URL is www.elite-carsales.co.uk/ecslightboxtest.html (http://www.elite-carsales.co.uk/ecslightboxtest.html). This is a very basic test page that has no user friendly layout because i was having the following problem: In DW CS4, live view the Lightbox2 works as I want it to. But once I upload to my URL & view the page the Lighbox effect doesn't work at all. I'm using Internet Explorer9 & safari on my iphone. I have tested another site www.wavecrestscuba.com/ (http://www.wavecrestscuba.com/) & the Lightbox in that site's gallery works as it should on both my laptop & iphone. Eventually i want to incorporate the Lightbox2 into a showroom page on my site which is part finished www.elite-carsales.co.uk (http://www.elite-carsales.co.uk).
I can post all the coding if req'd.
Pls help

gentleone
11-16-2011, 06:16 PM
I've move this thread out of the Introduction board.

The large images for the lightbox are not in the directory you say they are. You didn't upload or forgot to upload them to that directory, or they are in another directory. So fix your img paths or check the directory.

hairybeard
11-16-2011, 06:42 PM
Hi gentleone, thanks for moving the thread & for your quick responce.
I checked my img paths & they were fine. But I've just re-linked them al again just to make sure.
All the thumbnails & larger imgs are all in the same folder. I've just done it & uploaded again but I've still got the same problem.
I can't understand why it's working in DW Live View & F12 but not on the internet.
Do you want me to post the code?

gentleone
11-16-2011, 06:55 PM
http://www.elite-carsales.co.uk/imgs/Sale Cars/Fiesta EO54XUV/PIC_0359a.JPG

If I follow the url above it gives a 404 error, so either the image is not there or the path is not correct. The spaces in your directory names might give you troubles... use dashes or underscores to connect the names and try again with that.

Do you want me to post the code?
No, url of the website is more then enough ;)

hairybeard
11-16-2011, 07:41 PM
I have just made sure all paths etc have no spaces, renamed relevant files & folders. I then had to input all the car imgs & links back into DW again. Same prob though - Lightbox works in DW F12 & LiveView but not on the internet.
By the way, just noticed there's a green line under "href="css/lightbox.css" in the source code. The full line is....
<link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" />.
When I hover over it it says "Found 2 errors in lightbox.css Affects:Netscape 8.0".
I've checked CSS as best as poss & made sure that the label images are pointing towards the correctly named folder etc etc but don't know what else to check.
btw what's an error 404?

DWcourse
11-16-2011, 10:30 PM
Looks like you got it sorted. the lightbox at carsales.co.uk/ecslightboxtest.html works for me.

gentleone
11-16-2011, 10:42 PM
Yes, it seems fixed now. Iit had to do with the spaces in the paths isn't it?

hairybeard
11-27-2011, 10:40 AM
Thankyou for your help - there were issues with file locations etc & uploading. I really appreciate your knowledge.
I do have another question which is on another post here.
Can Lightbox2 be integrated within a spry dataset? If so how?

Mike Braver
06-20-2012, 11:39 PM
I am also having problems with lightbox. It works perfectly in preview mode but after uploading my site to the web, it doesn't work. Images only show up in a new window. If anyone has any ideas on what i could be doing wrong please let me know.

Thanks!

DWcourse
06-20-2012, 11:55 PM
Mike, the best way to get an answer would be to include a link to the page where your lightbox isn't working. Most likely it's a linking issue.

Mike Braver
06-21-2012, 12:55 AM
DWcourse

That makes sense lol. Here's one of the pages that use the lightbox feature.

Thanks!

http://michaelshalpin.com/graphic_design.html

Mike Braver
06-21-2012, 01:01 AM
DWCourse

That would probably help lol. Here's one of the pages that uses the lightbox feature.

http://michaelshalpin.com/graphic_design.html

Thanks!

Mike Braver
06-21-2012, 01:03 AM
DWcourse

That would make sense. Here's one of the pages that uses the lightbox feature.

http://michaelshalpin.com/graphic_design.html

Thanks

DWcourse
06-21-2012, 01:31 AM
You've linked to JS and CSS files in the lightbox2 directory but that directory doesn't exist on your site.

Mike Braver
06-21-2012, 03:28 AM
I finally got it. The operating system I uploaded my site to was Linux and it is case sensitive. I didn't realize I had the L capitalized in lightbox2. Stupid mistake. My web design old professor would be disappointed.

Thanks for the help though. Much appreciated.