PDA

View Full Version : MySQL website management


SilverAce
11-14-2011, 09:05 PM
Does anyone else use phpMyAdmin to edit their MySQL's? I have been trying to get one to work with my website but I can't seem to import my file. It says every time.

"MySQL said:

#1142 - CREATE command denied to user 'CouponCowboy1'@'72.167.233.37' for table 'Admins' "


The problem is that I haven't given my database full rights to import and export stuff. My question is: How do I give it full rights?

I have looked everywhere and go nothing on how to edit the databases admin powers. I hope someone else has done this or knows how to do it. Thanks.

edbr
11-15-2011, 01:37 AM
is this a live server or a testing server?

SilverAce
11-15-2011, 02:12 AM
Its live. I sent in a message to godaddy. No response yet.

DWcourse
11-15-2011, 02:35 AM
Its live. I sent in a message to godaddy.

Good luck with that. In my experience everything on GoDaddy is harder to accomplish than it needs to be and support isn't all that helpful.

edbr
11-15-2011, 03:08 AM
not used them but in yur control panel is there a mysqldatabase wizard? many servers disable phpmyadmin's ability to give permissions directly

johnMoss
11-15-2011, 03:53 AM
Once you've logged in to your database in GoDaddy you should expect to see the set permissions box. If you have more than one database active, you will not see it, as they don't allow this setting for more than one database per host package. If this is not the case, scratch the email routine & call them. Getting permissions set to 'all' will solve the problem.

SilverAce
11-15-2011, 03:35 PM
not used them but in yur control panel is there a mysqldatabase wizard? many servers disable phpmyadmin's ability to give permissions directly

There doesn't seem to be one.

John, I am going to check your idea out now.

SilverAce
11-15-2011, 03:40 PM
Once you've logged in to your database in GoDaddy you should expect to see the set permissions box. If you have more than one database active, you will not see it, as they don't allow this setting for more than one database per host package. If this is not the case, scratch the email routine & call them. Getting permissions set to 'all' will solve the problem.

No luck on the box. I looked everywhere. I guess I will just call them. Hopefully I have have an update for you guys so other people don't have this problem.

SilverAce
11-15-2011, 10:07 PM
Wow, godaddy customer service is terrible. I have to call them later today.

johnMoss
11-15-2011, 10:27 PM
Where are you calling from? I never have to wait more than 2 or 3 minutes...

SilverAce
11-15-2011, 10:47 PM
Where are you calling from? I never have to wait more than 2 or 3 minutes...

Haven't called, just email. I hope the phone is better.

SilverAce
11-16-2011, 10:22 PM
Alright, here we go boys! I talked to Godaddy, and they do their MySQL differently.

What you need to do it is

1. Make your MySQL database in their web hosting control center
2. Go into your FTP and upload your SQL file into the _db_backups folder
3. You go into the control center for the databases you have made and click restore on the selected databse you want it in.
4. Select the file and press restore.
5. Wait for the restore process to finish (this is on their end)

The guy said you can do it the way I was doing it and said I shouldn't have an issue, but this is just as good... I guess. Hope this helps someone out.

johnMoss
11-16-2011, 10:54 PM
It most certainly will. Thanx for posting.