PDA

View Full Version : Upload problem with DW 5.5


tombo
09-21-2011, 08:51 PM
I just upgraded from DW 5.0 to DW 5.5 and when I attempt an upload to my site, I cannot upload the index.php to the root directory. All the other files in the root and sub-directories load fine; it's only that particular file. I get the error:index.php - error occurred - An FTP error occurred - cannot put index.php. Access denied. The file may not exist, or there could be a permission problem. Make sure you have proper authorization on the server and the server is properly configured.
I have tried a number of sever settings and still get the same problem. If I open the site in 5.0 index.php uploads fine. I'm on a MAC with Snow Leopard. My provider is GoDaddy and they have been informed of this problem and can't seem to figure it out.

I also tried re-defining the server and still get the same error. I was able to rename index.php on the remote server to index_x.php, then upload index.php from my system renamed as index_y.php. Once on the remote server I was able to change it back to index.php. This is happening on 2 different sites I have on Godaddy. I have sites on FATCOW and am not having this problem with 5.5. Also if I use another FTP program it loads fine.

I let this rest for a half a day and now I can't get any files to load in the root directory. However, all files in the sub-directories still load fine.

Any ideas???

DWcourse
09-21-2011, 11:04 PM
I mention that here: http://www.dwcourse.com/dreamweaver/dreamweaver-cs5-5-ftp-bug-affects-godaddy-users.php

According to Adobe the (hard to comprehend) solution is to "Locate a file called 'webformmailer.php' in the root folder of your FTP server, and then either move it to another folder or delete it."

Although I've heard rumblings of even non-GoDaddy users having FTP issues with 5.5.

tombo
09-21-2011, 11:27 PM
WOW!!

Sure enough that was the problem! I fixed the site I was working on and it uploaded fine. Then I went to another GoDaddy site I maintain and without fixing it I tried it and it failed. Then moved that file to another directory and sure enough it uploaded fine!

Thanks!!