PDA

View Full Version : CSS Menu not working on sub-levels


RegionalRhythm
09-16-2011, 05:56 PM
Another problem! When I go onto one of the sub-level directories from my CSS menu, if I'm in the root folder, it works. But if I'm trying to get back to any of the root folders from the sub-menu, even though I've linked to the root folder CSS menu, it always appends it with the folder I'm in. For example, here's a link to my test:

www.regionalrhythm.co.uk/Test/index.php

When About Us/Vacancies is clicked it goes to the vacancies page but when I try to get back to the index page from there, instead of going to index.php it goes to About-Us/index.php which, obviously goes nowhere. What am I doing wrong? Do I need to put a new Navigation Bar file in each directory, pointing to the right places, can I really have just one navbar that works across the site?

edbr
09-17-2011, 01:59 AM
your index (home page is http://www.regionalrhythm.co.uk/Test/index.php

vacancies http://www.regionalrhythm.co.uk/Test/About-Us/Vacancies.php

so when you have yout home link as 'index.php it is relative to the page , it should be /index.php or absolute http://www.regionalrhythm.co.uk/Test/index.php

edbr
09-17-2011, 02:09 AM
i see you are maidstone based. i lived there for quite a few years if you would be interested in salsa teaching maybe you might check out http://www.facebook.com/pages/Salsa-Heart/198776773491446. although based in leigh , Gareth has links with maidstone and may be a connection for you

RegionalRhythm
09-17-2011, 10:56 AM
Thanks for both of your posts :) I have one more question - some of my drop down boxes have turned black for some reason (they're supposed to be blue). I can't see a pattern as it's happened to drop downs that do and don't link to another page. Do you know why this is, or what I can do to stop it/change it back?