PDA

View Full Version : Need Explorer & Safari Help/hack


BizzyWizz
09-16-2011, 01:28 PM
http://www.bizreka.com/_adPages/sampleAds.html

The above is the link to my demo page. I have an embeded YouTube video. I'm using SPRY vertical menu.

Problem: When I click on the MAP link in the ad above the video and the pop-up overlays the video in Explorer and Safari. It doesn't do this in Chrome or Firefox.

I don't have the demo links set in the navigation next to the video, but when I had done this previously, all the pop-ups fell behind the video in Explorer and Safari. I thought it was something I was doing incorrectly, so rebuild the page, but it's still happening.

I think I need to put in some sort of hack code for Explorer and Safari, but I'm such a newbie at this stuff. I tried changing the display in the CSS for the Vertical Spry menu from "inline" -- the default -- to "block" but that didn't do anything, so changed it back. My z-index default for the spry is 1020 and I set a z-index for the video at 100 -- didn't do anything.

I don't know how to get this to work -- it's probably something really easy for your techy people, but it has me pulling my hair out (again).

Any help would be appreciated. Thank you.

BizzyWizz
09-16-2011, 02:01 PM
Sorry for posting this thread -- but, maybe it will help others. After hours of looking, I actually found the solution on a site, here's the link.

http://www.projectseven.com/support/answers.asp?id=127

It was an easy fix, but not something I would have figured out on my own. There are solutions for problems with embedded Flash movies, YouTube with parameters and without (mine was without), photo slideshows (jsQuery) etc.

The answer to mine was to add this after the code for the video:
?wmode=transparent

So, my code for the iframe insert looks like this:

<iframe width="480" height="300" src="http://www.youtube.com/embed/t3Y4H9OZPdI?wmode=transparent" frameborder="0" allowfullscreen></iframe>

Hope this helps someone else having problems with this.