PDA

View Full Version : Spry Horizontal Menu not working in IE9


jnoent
07-09-2011, 01:59 PM
Hi,

I am new to webhosting and dreamweaver and I'm having a bit of an issue with my spy horizontal menu bar submenus dropping down in IE9. It works fine in IE8. My website is www.bellacakesonline.com (http://www.bellacakesonline.com). Here is the code for the menu bar.

<ul id="MenuBar1" class="MenuBarHorizontal">
<li><a href="index.html">Home</a> </li>
<li><a href="flavors.html">Flavors</a></li>
<li><a class="MenuBarItemSubmenu" href="cakegallery.html">Cake Gallery</a>
<ul>
<li><a href="wedding.html">Wedding Cakes</a> </li>
<li><a href="custom.html">Custom Cakes</a></li>
<li><a href="cupcakes.html">Cup Cakes</a></li>
</ul>
</li>
<li><a href="classes.html">Decorating Classes</a></li>
<li><a href="company.html">Company</a></li>
<li><a href="contact.html">Contact Us</a></li>
</ul>

and here is the source code for the sites index page.

-->
</style>
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
<script src="SpryAssets/SpryMenuBar.js" type="text/javascript"></script>
<!-- TemplateBeginEditable name="head" -->
<!-- TemplateEndEditable -->
<link href="../SpryAssets/SpryMenuBarHorizontal.css" rel="stylesheet" type="text/css" />
</head>
<body>

<div class="container">
<div class="header"><a href="#"><!-- TemplateBeginEditable name="header" -->
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="960" height="184" id="FlashID" title="mainlogo">
<param name="movie" value="../logo.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="../logo.swf" width="960" height="184">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="

edbr
07-11-2011, 04:15 AM
i cant see the attributes for <div class="header">