PDA

View Full Version : Live Data won't work.


Futuristic
06-28-2011, 10:01 AM
Hey all,

I've been going through the tutorials in Dreamweaver 4: The Missing Manual. Everything's been just dandy until I got to the database section. In fact, even that was fine: MAMP worked fine, phpMyAdmin worked fine, the database loaded properly. Everything worked. But then I did something—I can't remember what, exactly—and now I can't access the database anymore. When I try the "Live Data" function, I get the following error: HTTP error 0 occurred while attempting to request the file http://localhost:8888/cosmo_shop/index_K4BFKN6X2S.php from the testing server.

Here are some possible reasons for the problem:

1) Files in ".../MAMP/htdocs/cosmo_shop/" folder that have the ".php" file extension are not being executed by the testing server.
2) The ".../MAMP/htdocs/cosmo_shop/" folder does not map to "http://localhost:8888/cosmo_shop/" URL on the testing server. Verify that the URL prefix maps to the root of your site.

Would you like to change the location of the testing server?

<NO>/<YES> First of all, what the heck is index_K4BFKN6X2S.php? My original file was just index.php. I never changed the name; looks like Dreamweaver did something weird.
Second, based on the above quoted error, can anyone infer what I actually did to cause the error and more importantly, how I can undo what I did??
Third, I tested the connection to the testing server from Dreamweaver, and there were no problems there, so MAMP and Dreamweaver are able to talk to each other just fine.
Fourth, I tried deleting everything, including the databases in phpMyAdmin, and starting all over from scratch, and I still get the same error when I try "Live Data".

I'm kinda dead in the water until I can get this issue resolved. :confused:

dhachler
07-10-2011, 10:23 PM
I am having the same problem with Dreamweaver CS3 and .asp files. Everything tests fine when setting up the testing server and linking to the database and I am able to set up the bindings panel but when I click the live data button I receive an HTTP error 12029...."the "asp" file extension are not being executed by the testing server."

Everything was working fine a few weeks ago. I let my project sit for a couple of weeks and the next time I tried to work on it, I received this error.

Please can anyone help?