PDA

View Full Version : uploading problems


coltheviking
04-13-2011, 09:58 PM
I am trying to upload new pages to an already existing website using dreamweaver. When I try to sync the local and remote folders I get a message saying" "unable to create remote folder". I don't do this often, but have been able to accomplish the task in the past. Now no luck. I have checked with my server and everything checks out on their end. I could use the ftp manager but have not used it in the past and would rather use the synchronization feature. I am not an expert at this and may have set something up wrong. Any help as I would like to solve this as quickly as possible.
Thanks

DWcourse
04-13-2011, 10:50 PM
Check you site definition/setup and make sure you have the correct Host Directory/Server Directory specified.

coltheviking
04-14-2011, 01:23 AM
Hi again
I don't have anything specified for the host directory setting. This has worked in the past. I am new at this but have managed in the past to keep things up and running. I feel that it is something simple that I have overlooked. Maybe my settings for root folder are wrong? I have attached my list of files as arranged in my home computer to see what you think my root folder should be specified.
And do I specify the default images folder the same as my root folder?
Thanks for any help you can give.

DWcourse
04-14-2011, 01:50 AM
Hi again
I don't have anything specified for the host directory setting.

If you're getting a "cannot create remote folder" the problem isn't on your computer. It's either:

1. A misconfigured server OR

2. You need to specify a host directory (as I said)

Connect to your server and look at the remote site. What folders are showing there?

coltheviking
04-14-2011, 04:33 PM
Here is a screenshot of the files on my remote folder. As you can see I somehow in my synchronization tries have created a public_html file inside the public_html file. I'm sure I am overlooking something simple in my work and how the files are arranged. I hope this will help you to see what I have done wrong. And what should I set for the host directory setting?
Thanks again.

DWcourse
04-14-2011, 04:38 PM
Right, you need to specify public_html as your host directory and on your local hard disk you should not have a public_html folder. (when you specify public_html as your host directory all the files/folders from your local web folder will be placed there.

coltheviking
04-14-2011, 04:57 PM
OK getting closer. Have changed the folder in my local site and set public_html as the host directory. Have attached screenshot now of the local site. When I synchronize do I use the Sculpture 2011 folder on the local site and the public_html folder on the remote site? Or do I use the top SCULPTURE.CA folder
Should be such a simple to figure out I know and I appreciate your knowledge.
It's just been such a long time since I have done this. And all I know is self taught so I may have learned the wrong way.

DWcourse
04-14-2011, 05:06 PM
First, you've downloaded a lot of stuff from the server you don't need.

Second, Sculpture 2011 should be your Local Root folder.

That would make Sculpture 2011 or your local drive map directly to public_html on the server.

coltheviking
04-14-2011, 05:15 PM
OK have changed my root folder. Now you can see my new local folder. What about the default images folder setting? Is it the same as the root, be blank or what?
Now do I upload this new folder using the blue up arrow and will it over write the old stuff on the remote folder? I guess that the extra folders were uploaded in the past because I didn't have the root folder setting right last time.
Thanks

DWcourse
04-14-2011, 05:48 PM
That looks right and if you have public_html as your server directory you should just be able to select everything and hit the upload arrow.

coltheviking
04-14-2011, 06:02 PM
I tried selecting site folder and uploading first, then tried selecting all the separate files and folders under the site folder, and each time got the following error. See attachment. Now what? Thanks

DWcourse
04-14-2011, 06:07 PM
Does you folder name actually have all those in it?

coltheviking
04-14-2011, 06:09 PM
Yes. It was designed by someone else and I have just done the work in Dreamweaver to get it web ready. Are those a problem?
I got rid of those and tried uploading again.
Now getting this error. An ftp error occurred - put spacer.gif. Access denied. The file may not exist or there could be a permission problem.

coltheviking
04-14-2011, 09:17 PM
This is a screenshot of the latest local site. Had some problems when changing the structure of my files. Think I have it right now. I hope. If I upload the local site will it write over the old public_html. And will all the extraneous folders be gone! Thank you

DWcourse
04-15-2011, 12:12 AM
That looks right. Uploading will overwrite any files with the same name/location but won't delete any other existing files.

coltheviking
04-15-2011, 12:25 AM
Hi if I upload the whole sculpture 2011 folder will the index page and its images overwrite the current index page. Or do I have to upload the sculpture 2011 pages then the index page and images separately? I have again included screenshots to show the local and remote folders.
Thank you

DWcourse
04-15-2011, 12:40 AM
Whatever you upload will end up on the server. If there is already a file with matching filename there it will be overwritten. Anything else on the server will not be affected.

coltheviking
04-15-2011, 12:53 AM
Thanks will try tomorrow.

coltheviking
04-15-2011, 01:18 AM
Hi again
I do want the new index page activated so my new pages are on the website and the old pages are gone. If I upload the whole sculpture 2011 folder which includes the index file will the new index page be activated. Or does it have to be uploaded outside of that folder into the remote public_html folder. That is do I upload the "sculpture 2011 pages" separately,then the index and images to activate the index page?