PDA

View Full Version : Jump list in a template


volvomad
04-12-2011, 08:52 AM
I'm basing a website on a template, and I'm having problems with a jump menu that will take you to the relevant position on the page. I have copied it directly from the original website so I know it is a good code, but it fails to work within the template. The template has 2 editable regions, and when I paste the code into the main region, the menu appears with the Go button, but it doesn't work. Can anyone help?

<head>
<meta http-equiv="Content-Language" content="en-gb">
<meta name="GENERATOR" content="Microsoft FrontPage 5.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="description" content="_your description goes here_">
<meta name="keywords" content="_your,keywords,goes,here_">
<link rel="stylesheet" type="text/css" href="style.css" media="screen" title="style (screen)">
<!-- InstanceBeginEditable name="doctitle" -->
<title>Company Name</title>
<script type="text/javascript">
<!--
function MM_jumpMenuGo(objId,targ,restore){ //v9.0
var selObj = null; with (document) {
if (getElementById) selObj = getElementById(objId);
if (selObj) eval(targ+".location='"+selObj.options[selObj.selectedIndex].value+"'");
if (restore) selObj.selectedIndex=0; }
}
//-->
</script>
<!-- InstanceEndEditable -->
</head>

<body leftmargin="0">

<div align="left">
<table border="1" cellpadding="0" cellspacing="0" height="1" id="AutoNumber1" width="878" style="border-style: none" fpstyle="1,000000000">
<tr>
<td height="1" style="border-style: none" width="216" align="center">
<font size="1"><a href="index.html">
<img border="0" src="images/logo2.gif" style="margin-left: 1; margin-right: 1" width="197" height="67"></a></font></td>
<td height="1" valign="bottom" style="border-style: none" width="656">
<h1 align="left" style="margin-top: 0"><b><u><font size="6">Company name</font></u></b></h1>
<div class="wrap" style="width: 761; height: 697">
<p align="left">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<b><i><font color="#FFFFFF">Company Description</font></i></b></div>
<p>&nbsp;</td>
</tr>
</table>
</div>
<div class="wrap" style="width: 761; height: 697">
<div id="nav">
<ul>
<li><a href="index.html">Home</a></li>
<li><a href="products.html">Products</a></li>
<li><a href="support.html">Support</a></li>
<li><a href="sales.html">Sales</a></li>
<li><a href="hire.html">Hire</a></li>
<li><a href="contact.html">Contact Us</a></li>
<li><a href="news.html">News</a></li>
<li>&nbsp;</li>
<li>&nbsp;</li>
</ul>
<div class="clearer">
&nbsp;</div>
</div>
<div id="main">
<h2><!-- InstanceBeginEditable name="EditRegion1" -->Representatives!<!-- InstanceEndEditable --></h2>
<!-- InstanceBeginEditable name="EditRegion2" --> <p align="left"> To provide a more efficient service to overseas customers
we have appointed a number of representatives to deal with sales and service
requirements in specific countries and regions. If there is an agent near
you please contact them in the first instance.</p>
<p align="left"> Currently we have representatives in the following countries:</p>
<form name="form1" id="form1" method="post" action="">
<select name="Select country">
<option value="" selected="selected">Select from list...</option>
<option value="#australia">Australia</option>
<option value="#belgium">Belgium</option>
<option value="#canada">Canada</option>
<option value="#china">China</option>
<option value="#denmark">Denmark</option>
<option value="#germany">Germany</option>
<option value="#nz">New Zealand</option>
<option value="#portugal">Portugal</option>
<option value="#netherlands">The Netherlands</option>
<option value="#singapore">Singapore</option>
<option value="#spain">Spain</option>
<option value="#thailand">Thailand</option>
<option value="#usa">USA</option>
<option value="#uk">UK</option>
</select><input type="button" name="Button1" value="Go!" onclick="MM_jumpMenuGo('Select country','parent',0)" />
</form>
<p>If your country isn't listed, please contact our UK manufacturing base.<br />
<a name="australia" id="australia"></a>
</p>
<h3 align="left">AUSTRALIA</h3>
<p align="left"><img src="images/as-t.gif" width="64" height="32" /></p>
<p align="left">Contact Name <br />
Co. name<br />
address 1<br />
address 2<br />
post code<br />
Australia</p>
<p>Tel -<br />
Fax N/A</p>
<p>E-mail - <a href="mailto:xxxx@xxxx.com">xxxx@xxxx.com</a><br />
Website - N/A<br />
<br />
<a href="#top" title="RETURN TO TOP">Return to top</a></p></p>
<p> <a name="belgium" id="belgium"></a></p>
<h3> BELGIUM</h3>
<p align="left"><img src="images/be-t.gif" width="64" height="32" /></p>
<p align="left"> Contact Name -<br />
Co name<br />
address 1<br />
address 2<br />
Belgium</p>
<p>Tel -<br />
Fax - </p>
<p>E-mail - <a href="xxxx@xxxx.com">xxxx@xxxx.com</a><br />
Website - N/A<br />
<br />
<a href="#top" title="RETURN TO TOP">Return to top</a> </p>
<h3><a name="canada" id="canada"></a>CANADA</h3>
<p><img src="images/ca-t.gif" width="72" height="36" /></p>
<p>Contact Name <br />
co name<br />
address 2 <br />
address 3<br />
Canada </p>
<p>Tel <br />
Fax </p>
<p>E-mail <a href="mailto:xxxx@xxxx.com">xxxx@xxxx.com</a><br />
Website <a href="www.google.com">www.google.com<br />
</a><br />
<a href="#top" title="RETURN TO TOP">Return to top</a> </p>

johnMoss
04-16-2011, 02:08 AM
Very simply you are running into link problems, but without being able to view the complete picture, it's all but impossible to see. Do you have this on a host for us to review, and if not, then go back and look at your reference links. Your problem is there...