PDA

View Full Version : local files on DW are showing broken image links


rennart
12-26-2010, 10:55 AM
hi,

I have just had to reinstall CS3 and now my local files on DW are showing
broken image links. The remote seems to be fine, so I tried 'get'ting files and copying onto local. But this doesn't seem to work.
What do I need to do to reinstate my image files?
How do I repair broken image links on local files?
Grateful for any advice, thanks.

Corrosive
12-26-2010, 12:39 PM
Hi Karen, moved to new thread.

rennart
12-26-2010, 05:13 PM
hello, didn't want to bother you!

Amazingly, have found the answer ---

pathname had been changed due to clean system reinstall.
Now I have put the name of harddrive back to the original name things
are loading!
:-D

DWcourse
12-26-2010, 06:44 PM
I've been caught by that one a time or two myself.

jmichae3
12-26-2010, 08:49 PM
hello, didn't want to bother you!

Amazingly, have found the answer ---

pathname had been changed due to clean system reinstall.
Now I have put the name of harddrive back to the original name things
are loading!
:-D
I had thought that one of the things that can cause a problem is relative vs absolute paths. with absolute paths, you can't view the image unless it's on the server and everything's configured on the server properly.

but the switch isn't automatic from what I remember when you change this in "manage sites".

DWcourse
12-26-2010, 09:08 PM
I had thought that one of the things that can cause a problem is relative vs absolute paths. with absolute paths, you can't view the image unless it's on the server and everything's configured on the server properly.

but the switch isn't automatic from what I remember when you change this in "manage sites".

When you preview from Dreamweaver, if you've set things up correctly, DW will preview an image which uses links relative to the site root (absolute paths).

And you're right switching from document to site-relative links only affects new links your create, it won't change existing ones.