View Full Version : Starting WAMP on startup

12-04-2010, 11:11 AM
For those on Vista and Windows 7 do you ever get annoyed when you click on an icon only to be asked by windows 'Are you sure you want to do this?' by windows Account Control

This also happens when you drop a restricted app into the start up directory on boot. Not the slickest of features in our world of paranoia.

If you would like WAMP or any other app to start on windows start up without the authorisation acceptance popup appearing then here is what you do...
Open Task Schedule (Windows 7 just type Task in search for programs)
In the left panel select Task Schedule Library
Select Create New task from right panel
In the 'General' tab settings give the task a name (Ive called mine WAMP)
Select the 'Run with highest privileges' check-box
In the Action Tab add a new 'Start Program' action and locate the WAMP exe through the browse button
On the 'Conditions' tab make sure the option 'Start the task if only on A/C power' is unchecked.
On the Desktop... right click > new > shortcut
Right click the shortcut and open properties
In the Target add the following

C:\Windows\System32\schtasks.exe /run /tn {task name}

Mine looks like this...

C:\Windows\System32\schtasks.exe /run /tn WAMP

make sure there are spaces as marked ^ /run ^ /tn ^ WAMP

Now move the shortcut into your startup directory and your dev environment will load on startup and be ready for you to start cutting some phat code

You can change the icon of the shortcut to match the app it opens by selecting change icon option from the properties of the shortcut. You will find the WAMP icon embedded inside the exe of WAMP so just choose the exe and the WAMP icon will become available to selectJob Done!

12-06-2010, 12:36 AM
i went to administrative tools >services there 2 entries wampapache and wampmysqld and changed the startup type to automatic that did the trick also

12-06-2010, 08:28 AM
That will start the deamon but not the app

12-06-2010, 08:51 AM
works on windows 7 though

12-20-2010, 10:25 AM
thanks for information

12-21-2010, 12:46 AM
ok ignored long enough, @opet if you do not prove your self not to be a bot very soon, you are history!