PDA

View Full Version : Adding links


GaryKC
11-30-2010, 08:31 PM
My site is hosted through my fathers site, making and uploading a new page isn't a problem, however, the links are displayed as www.myfatherssite.com/mysite/anything.html (http://www.myfatherssite.com/mysite/anything.html) instead of www.mysite.com/anything.html (http://www.mysite.com/anything.html) in all browsers. What am I doing wrong?

gentleone
11-30-2010, 09:29 PM
What am I doing wrong?
Nothing! That's how it works.
You have just created a sub directory (mysite) on your fathers web server, so the domain name of your father will always be in front of it.
If you don't want that, then you must get/buy your own domain name with its own web server.

GaryKC
11-30-2010, 09:49 PM
I own the domain name and have added pages in the past that are linked without his domain name showing. It's something I'm doing now when I link a new page that I'm having a problem with. I thought that perhaps someone else has had the same occur and can help, thanks anyway.

DWcourse
11-30-2010, 11:36 PM
Sounds like you haven't correctly defined your local site. Your local root folder should be the folder with the mysite pages. Your father's site should be defined totally separately.

It might also help to have a link so that we could look at the actually links in your code.

GaryKC
11-30-2010, 11:57 PM
Assuming a visitor starts on this page http://www.usstusk.com/crewphotos.htm (http://www.usstusk.com/crewphotos.htm)
and then clicks on Don Fudge's name it works fine, if however your click on Jack Fradette's name (added today) it links to my fathers site. Is this the link you requested DW? I think my problem may be here, host directoryhttp://www.dreamweaverclub.com/forum/images/attach/jpg.gif

DWcourse
12-01-2010, 12:30 AM
Well, you're actually framing this page: http://www.donparker.us/usstusk/crewphotos.htm (which makes no sense). So unless you link using the full url including "http://www.usstusk.com/" the links will naturally point to the donparker.us site.

GaryKC
12-01-2010, 12:57 AM
Well, you're actually framing this page: http://www.donparker.us/usstusk/crewphotos.htm (which makes no sense). So unless you link using the full url including "http://www.usstusk.com/" the links will naturally point to the donparker.us site.
I know you're trying to help, I'm framing, OK, have no idea what framing is or how I did it. I'll keep plodding along, thanks.

DWcourse
12-01-2010, 04:22 AM
look at the html source for the page at http://www.usstusk.com/crewphotos.htm


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html>

<head>
<title>uss tusk </title>
<META name="description" content="submarine"><META name="keywords" content="submarine">
</head>
<frameset rows="100%,*" border="0">
<frame src="http://www.donparker.us/usstusk/crewphotos.htm" frameborder="0" />
<frame frameborder="0" noresize />
</frameset>

<!-- pageok -->
<!-- 06 -->
<!-- -->
</html>

That means it's actually displaying the page at http://www.donparker.us/usstusk/crewphotos.htm

GaryKC
12-01-2010, 05:08 AM
OK, I was able to link (as you suggested) using the full url to some pages. I can't however fix the links made by buttons on the index page, they appear to be linking to just my site, but they're not. Thanks again DWcourse or is LT COL?