PDA

View Full Version : Pop Up Problem And Youtube Video Embed


dean19693
11-19-2010, 05:40 PM
Hello,

I'm working with an old version of dw...dw8...but I don't think it matters for this issue.

I have pop up screens which have youtube video embeds on them.

When the pop-up screen is closed, the video continues to play. It only does this in internet explorer.

The site is http://bit.ly/duL7AA (click on a thumbnail of one of the videos).

I've always hated ie... unfortunately newbies use it.

Is there a way to work around this issue?

Thanks!

Corrosive
11-19-2010, 06:01 PM
Yes, that's odd. have you tried using iframes in the pop-up rather than inline divs? At the moment you close the div but it is still there. If you use an iframe in your pop-up it should close the page and stop the vid.

dean19693
11-21-2010, 01:32 AM
Thanks for the fast reply!

Actually I'm not a web designer...but the guy I hired is busy or something.

I'll paste the code and if you could be so kind as to show me on the first part where i paste the <iframe>?


<div id="blanket" style="display: none;"></div>
<div id="popUpDiv1" style="display: none;">
<div class= "close_button_popup"><a href="#popup_start" onclick="popup('popUpDiv1')"style="color:#ff0000">Close</a><br /> </div>
<div class="individual_video"><br />
<embed width="360" height="227" type="application/x-shockwave-flash" allowFullscreen="true" allowNetworking="all" wmode="transparent" src="http://static.photobucket.com/player.swf" flashvars="file=http%3A%2F%2Fvid410.photobucket.com%2Falbums% 2Fpp190%2FFindStuff2%2FFunny%2FFunny%2520Videos%2F Random%2520Funny%2FRaveinalibraryVideobyThorsten-MySpa.flv"> </div>

<div class="individual_video"><br />
<object width="360" height="227"><param name="movie" value="http://www.youtube.com/v/PB0nZQP6rRI?fs=1&amp;hl=en_US&amp;rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/PB0nZQP6rRI?fs=1&amp;hl=en_US&amp;rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="360" height="227"></embed></object> </div>
<br />
<div class="individual_video"><br />
<object width="360" height="227"><param name="movie" value="http://www.youtube.com/v/sQ3gF0Al9sg?fs=1&amp;hl=en_US&amp;rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/sQ3gF0Al9sg?fs=1&amp;hl=en_US&amp;rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="360" height="227"></embed></object> </div>

<div class="individual_video"><br />
<object width="360" height="227"><param name="movie" value="http://www.youtube.com/v/dK2DJE1uqxQ?fs=1&amp;hl=en_US&amp;rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/dK2DJE1uqxQ?fs=1&amp;hl=en_US&amp;rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="360" height="227"></embed></object> </div>


</div>


__________________________________________________ _________

Thank you!

Corrosive
11-21-2010, 06:44 AM
Well it depends on whether or not the pop-up you are using supports iframes. I know that this one does; http://www.no-margin-for-errors.com/projects/prettyphoto-jquery-lightbox-clone/ Maybe swap them over?