PDA

View Full Version : Template Problem


patodjs
09-11-2010, 08:17 AM
Hi and Thank you for taking the time and read this!!

Well I have a website and I have been working on it for about 6 months, so far im happy with the content and the images, but I created the site based on a table template and my SEO its really bad and I even have problems with browsers, so I decided to get a new template its a CSS template that I got from a site.

Now that I have all the tools and the template, the content etc, the question is:

1.Whats the first step? Should I copy the old index content (bad template) into the new and then update the page?

2.how can I manage the template so Ill be able to make changes onces and not to every single page?


Ill probably have some more questions later LOL :mrgreen: :mrgreen:

Thank you !!!

Corrosive
09-11-2010, 08:58 AM
Have a look at the tutorials section of this site. There is a quick run down of using templates.

DWcourse
09-11-2010, 11:01 PM
Place the new template in your existing Templates folder.

When you apply a new template to an existing page (menu: Modify>Templates>Apply Template to page, Dreamweaver offers you a chance to tell it where to put the content from the existing editable regions so that you can map the content to new areas.

A quicker solution is to make sure the editable regions in the old and new templates match. That way the content will automatically flow into the proper region when you apply the new template.

BTW, I'd back up first before I messed around with this.

patodjs
09-15-2010, 09:45 AM
hi and thank you for your answers

Now almost everything its working good the template its fine BUT only on my computer seems to be good but
the remote server have the CSS file I checked and the file is there but when you check out my website (www.allmoneylovers.ws) looks very messy and obviously the css file its not working or doesn't recognized it I dont know what happens because when I preview the pages on dw everything looks good but when I open my site on the internet looks like hell.

I noticed that every time I create a new page a get a message like this:

http://i55.tinypic.com/sxhh1i.jpg

then after that message I clicked copy and I got another message like this

http://i55.tinypic.com/dbrz14.jpg

by the way I dont know if this is normal but every time I change my content the page update as soon as i saved it, but every time I change something on my template the changes will appear even a day after. I dont know why it takes so long :S

thank you very much

DWcourse
09-15-2010, 06:53 PM
Dreamweaver is telling you the issues.

In your template (in a locked area) you have linked to a file outside of your local site folder. You can tell because the link starts with File:///. You need to move the file file:///C|/Users/Patto/Desktop/template/default.css into your site folder. Relink to it from your template. Allow all the pages to update and then reload the site.

The styles work when you preview because the file is on your computer. However your coomputer isn't acessible from the internet.

patodjs
09-16-2010, 07:17 AM
thank you very much you guys really solve my problem.

Now I dont know if this is normal but ,when I update editable regions on the template, or im just creating a new page based on that template the page update as soon as i saved it, and Im able to see it from the internet but every time I change something on my template or on a non-editable region the changes will appear even a day after. I dont know why it takes so long :S

any idea?

Thanks

DWcourse
09-16-2010, 07:37 AM
Do you have Automatically upload files to server on save checked in the Remote info tab of the Site Definition.

If so it will upload files when you save them. However when you update a template's non editable region and allow the changes to pass though you don't actually use the save command on the individual files. So you'll need to upload them manually.

patodjs
09-20-2010, 07:45 PM
yes i do have the Automatically upload files to server on save. but yeah like I said the html files they upload automatically on the server, but my template still the same and I put the file (dwt) manually. any ideas???

Thank you

DWcourse
09-20-2010, 08:10 PM
When you update a template and save it. Then the changes to non-editable regions are passed through to the pages based upon the template. But, since the pages are not open, they aren't being saved the normal way. So you have to put them manually.

BTW, it's not necessary to upload the template for your site to work properly (although it doesn't hurt anything either)

patodjs
09-22-2010, 08:17 PM
thank a lot for your help.

I changed my sidebar and is editable region but when I changed anything on the sidebar of the template only the new pages get the changes but not my index or the pages that I create before I create the editable region.

its there a way so I can update all the pages and having the editable region

Thanks

DWcourse
09-22-2010, 08:20 PM
Changing an editable region in a template does not affect pages already created from the template. The template only controls the non-editable region of the pages.