PDA

View Full Version : Jquery - Not Working


cocoonfx
09-03-2010, 10:31 AM
Hi Chaps

I have 3 different JQuery scripts in one HTML page

1 - is a image gallery
2 - is a quote from client effect
3 - is mp3 player

I can get 2 of the scripts to work but either the quote or the Mp3 player does not work depending on where I place the code. Can someone point me in the direction on where I am going wrong.

www.test-cocoonfxmedia.co.uk/smf/newtest3.html (http://www.test-cocoonfxmedia.co.uk/smf/newtest3.html)

HELP!

DWcourse
09-03-2010, 04:09 PM
can you post a link?

Corrosive
09-03-2010, 05:03 PM
can you post a link?

Your eyes going JC or do you just need a good night's sleep?

www.test-cocoonfxmedia.co.uk/smf/newtest3.html

DWcourse
09-03-2010, 05:59 PM
Your eyes going JC or do you just need a good night's sleep?

Yes! :???:

DWcourse
09-03-2010, 06:02 PM
I don't know that it would cause the issue but you do link to two different versions of jquery. Could they be overwriting functions?

Corrosive
09-03-2010, 06:06 PM
Yes! :???: He, he. Good answer!

cocoonfx
09-05-2010, 02:56 PM
Hi Guys

Getting closer to solving it. I downloaded 1.4.2 from Jquery and got all 3 scripts to use this I called jQuery.js

All three scripts worked but now the lightbox appears behind the image slider... which is quite amusing but I can't quite figure out how to change... Would the z-index in the css be the culprit? new link

http://www.test-cocoonfxmedia.co.uk/smf/test.html

Turn your speakers off as there is sound!

cocoonfx
09-05-2010, 05:38 PM
hi all cracked it... just need to put a z-index on the image slider to 90 and it fixed it straight away.... one day I get my head around css :o)