PDA

View Full Version : Plug-ins


dudesitan
07-25-2010, 07:47 AM
Hello. I am new to this forum. I have two related problems I need to resolve.

I have inserted a flash plugin on a web page. The flash video is set to play automatically with no loop.

It works perfectly on my Mac (with both Safari and Firefox).

However, on Windows 7 the flash video does not play at all on Safari, Firefox or Explorer. Instead the viewer is offered a choice to download the video.

I also have a simple MP3 plugin on another page. This again plays automatically on my Mac on any browser, but will not play on Windows 7 because it does not recognise the mime on any browser.

I am a novice with regards to Dreamweaver. Any help would be appreciated. Thank you.

edbr
07-26-2010, 01:47 AM
looks like a coding problem can you provide a link or post the code you used

dudesitan
07-26-2010, 07:39 AM
Thank you edbr.

Can I take the second issue first, i.e. the mp3 plugin not playing on Windows 7. I have checked again and somewhat bizarrely it now works on Firefox and Explorer. However still not on Safari for Windows (some type of mime missing apparently).

Here is the code for that:

<tr>
<td height="431"><div align="center">
<p><img src="images/dude.jpg" alt="dude" width="521" height="396" /><br />
<embed src="plugins/Track_01.mp3" width="32" height="32"></embed>
</p>
</div></td>
</tr>

As far as the first problem is concerned, i.e. Flash videos not playing automatically, I have simply swopped the Flash files for Quicktime files and these work splendidly well on all browsers using Windows 7.

However, I'm never going to learn if I keep taking the easy option, so here is the code I used when the Flash files were in place:

<tr>
<td valign="top"><div align="center">
<embed src="plugins/Germany_England.swf" width="640" height="360" loop="false"></embed>
</div></td>
</tr>

edbr
07-26-2010, 08:48 AM
the problem i think is using embed which is disregarded by browsers look at usinhgg javascript tp display using swfobject by my choice

dudesitan
07-26-2010, 08:53 AM
OK. Need to do a bit more research!. Many thanks.