PDA

View Full Version : FTP/Contribute/Dreamweaver CS4 access denied issue


joshob
07-19-2010, 06:20 PM
Hello and thanks for the forum,

I've been researching this issue for two full days now, as it's the only thing preventing me from moving this website to a new server. IIS 7 Server 2008

I have a user with Dreamweaver/Contribute CS4. When trying to change or upload a file they get this response.

directory.html - error occurred - There is a problem renaming this file on the server. Verify that you have permission to rename files on the server. If the problem persists, you can turn off rollbacks in the Contribute Administration settings.
directory.html - error occurred - An FTP error occurred - cannot put directory.html. Access denied. A file or folder with that name already exists, or there could be a permission problem.

File activity incomplete. 2 file(s) or folder(s) were not completed.

Files with errors: 2
directory.html
directory.html

I've enabled and disabled passive ftp numerous times. Turning off rollbacks avoids this error but the user would like to use rollbacks. Thus not an option. Have enabled the Use Alternative Publish Method, this does not help. I have searched it seems hundreds of google pages to see if I'm missing permissions or if this is a Dreamweaver contribute problem. Many thanks to anyone that can crack this one.

DWcourse
07-19-2010, 08:10 PM
Did you rename a file to/from directory.html?

Have you tried deleting the offending file and letting the client upload through Contribute?

And what about just setting the client up from scratch as if it were a new site?

joshob
07-19-2010, 08:15 PM
Actually she is just trying to push the same file that has been updated to the server. Have not tried deleting any files.

The user used a machine that had not been setup to manage the site that is on the new server (test site). She syncronized the site on the new server and so far has been having this issue.

DWcourse
07-19-2010, 08:24 PM
Is it just one file or all files?

It would be interesting to be able to look at the problem file and see if there's some issue at or around the code:

FONT='Times New Roman','serif'

Could it be a permissions issue on the serveer. I assume that outside D=Contribute you can upload and change?

joshob
07-20-2010, 02:52 PM
It is any file that is already there, but that she has updated. It sometimes says check to see if the user has privelages to rename. The users have full permission on the directory and in FTP. The Font=Times New Roman thing for some reason showed up on this forum when I done the copy and paste from the error. Don't know why it didn't keep between the email and here.

Yes, if I use any other FTP MSDOS, etc, then no issues. Only with Contribute. I keep feeling like it's a setting on the server as well, but if that is the case then why do other clients work. What is the rollback doing that the server does not like or Contribute does not like. Once that is disabled it works fine.

DWcourse
07-20-2010, 03:36 PM
Rollback does rename files and (I believe) move them to another directory as part of the process of saving it as a backup. You don't do that with normal ftp. so I'd guess there is a setting on the server that is preventing that. I'd put in a support ticket with the host.

DWcourse
07-20-2010, 03:40 PM
I'm not familiar with IIS permissions but I think the user might need the Modify permission checked.

joshob
07-21-2010, 03:17 PM
This issue is resolved. Sorry I didn't give all the info, but I was the server administrator. I had an idea to give the user local admin rights to the server. Once I did that it cleared the problem right up. Now I don't know if that is best practice but for now it's working.

If anyone can tell me if this is or is not best practice and what I can do to get around it, that would be great.

Thanks,