PDA

View Full Version : Dreamweaver Dropdown Menu not working??


petes2005@gmai.com
07-18-2010, 02:39 PM
Hi,
I am new to web development and am currently trying my hand at developing a new site for my Dad. So far all is going well except when trying to insert a dropdown menu in the navigation bar. Im using Dreamweaver 8 and have tried creating a 'hotspot' over one of the navigation buttons. The problem is that when i add the 'pop up menu' to the hotpspot and then go to view in a browser, all the buttons to the right off the hotspot are pushed onto a new line. I have trawled the net looking for a solution to this problem and as of yet cannot find anything. If anyone has any ideas on what i may be doing wrong then any information would be much appreciated.
All the best.

edbr
07-19-2010, 01:33 AM
welcome to the forum. we will need to see your code to help so either post it (in code blocks) or provide a URL if it is live

petes2005@gmai.com
07-19-2010, 10:42 PM
Hi Edbr,
below is the html code for my navbar div along with the imagemap that i am trying to insert. I have tried creating a navbar CSS rule and have played about with absolute positioning to no avail. If you have any ideas they would be much appreciated. Ive uploaded the test page i have tried this on and can be found here: http://www.acecoop.ie/home2.html (the drop down menu is not displayed here for some reason either but the navigation buttons are pushed onto a new line for some reason??)

<div id="navbar">
<img src="images/navbar/left_end.gif" /><img src="images/navbar/filler.gif" /><img src="images/navbar/filler2.gif" width="35" height="40" /><img src="images/navbar/filler.gif" width="84" height="40" /><a href="index.html"><img src="images/navbar/rollover/images/home2.gif" width="118" height="40" border="0" /></a><a href="about.html"><img src="images/navbar/AboutUs.gif" width="117" height="40" border="0" id="Image2" onmouseover="MM_swapImage('Image2','','images/navbar/rollover/images/AboutUs2.gif',1)" onmouseout="MM_swapImgRestore()" /></a><a href="join_now.html"><img src="images/navbar/JoinNow.gif" width="115" height="40" border="0" id="Image3" onmouseover="MM_swapImage('Image3','','images/navbar/rollover/images/JoinNow2.gif',1)" onmouseout="MM_swapImgRestore()" /></a><a href="documentation.html"><img src="images/navbar/Documentation.gif" name="Image4" width="118" height="40" border="0" usemap="#Image4Map" id="Image4" onmouseover="MM_swapImage('Image4','','images/navbar/rollover/images/Documentation2.gif',1)" onmouseout="MM_swapImgRestore()" />
<map name="Image4Map" id="Image4Map">
<area shape="rect" coords="11,6,102,30" href="#" onmouseover="MM_showMenu(window.mm_menu_0718183023_0,11,30,null ,'Image4')" onmouseout="MM_startTimeout();" />
</map>
</a><a href="contact.html"><img src="images/navbar/Contact1.gif" width="117" height="40" border="0" id="Image5" onmouseover="MM_swapImage('Image5','','images/navbar/rollover/images/Contact2.gif',1)" onmouseout="MM_swapImgRestore()" /></a><a href="links.html"><img src="images/navbar/UsefulLinks.gif" name="Image6" width="117" height="40" border="0" id="Image6" onmouseover="MM_swapImage('Image6','','images/navbar/rollover/images/UsefulLinks2.gif',1)" onmouseout="MM_swapImgRestore()" /></a><img src="images/navbar/filler2.gif" width="35" height="40" /><img src="images/navbar/filler.gif" width="84" height="40" /><img src="images/navbar/filler.gif" width="84" height="40" /><img src="images/navbar/filler2.gif" width="21" height="40" /><img src="images/navbar/RightEnd.gif" width="36" height="40" />

</div>

edbr
07-20-2010, 07:36 AM
cant see ant attributes for #navbar , that might be your position problem