PDA

View Full Version : missing swf after moving and updating links...


gore.m
07-08-2010, 11:42 AM
Hello,

I wanted clean up my project and to move files to different folders, so I used "site manage". After moving html I updated links. Everything works fine beyond flash gallery. Swf is missing, there is only blank space. How can I connect it?

Page before cleaning:
http://www.adelajizvecerela.cz/4/svatebni/svatebni.html

Page after cleaning:
http://www.adelajizvecerela.cz/4/svatebni.html


thanks you very much

Corrosive
07-08-2010, 01:38 PM
Just change the file path to match where the swf exists.

gore.m
07-08-2010, 01:53 PM
Just change the file path to match where the swf exists.

Thanks you for your reply!
I understand it is problem of path, but I dont know what to do with this 8-)
Im very happy I got flash content inside :mrgreen:

I went throught html and all attached files to find path but I heavent find anythink like this. I have tried add some codes I found on internet but it doent work...

Can you help me more?

thanks y

Corrosive
07-08-2010, 04:55 PM
I don't seem to be able to view >> source correctly on your site. Please post the code underneath 'Galerie' where the flash appears.

edbr
07-09-2010, 01:15 AM
http://www.adelajizvecerela.cz/preview.swf
not found

gore.m
07-09-2010, 07:36 AM
Please post the code underneath 'Galerie' where the flash appears.

<p>Galerie</p>
</div>
<div id="flashcontent"><strong>Pro zobrazení obsahu, je nutné mít nainstalovaný nebo aktualizovaný Flash Player.</strong></div>
<div class="nadpisblack" id="nabidka">
<p>Nabídka</p>
</div>
<div class="boxtext" id="nabidkaTEXT">
<p> </p>
<p>&nbsp;</p>
<p>Naše květinářství nabízí vše, co ke svatbě patří - <strong>svatební kytice, kytice pro družičky, kytice pro matky, klopy | korzáže, myrty a myrtové věnečky, výzdoby aut, stolů i další sortimen</strong>. Vše pro váš jedinečný okamžik.</p>
</div>
<script type="text/javascript">
//<![CDATA[

var so = new SWFObject("svatebni/preview.swf?keepSelected=t&selectedWindow=0&imageWidth=315&imageHeight=300&sWidth=547&sHeight=300", "sotester", "547", "300", "8", "#ffffff");
flashvars.folderPath = "svatebni/";
so.addParam("allowFullScreen", "true");
so.write("flashcontent");

//]]>
</script></div>

gore.m
07-09-2010, 07:39 AM
http://www.adelajizvecerela.cz/preview.swf
not found

Yes, its because I move it to different folder, it is here http://www.adelajizvecerela.cz/svatebni/preview.swf
and I dont know how attach file to java script again, in new folder.:(

edbr
07-09-2010, 08:02 AM
you have this line

var so = new SWFObject("preview.swf?keepSelected=t&selectedWindow=0&imageWidth=315&imageHeight=300&sWidth=547&sHeight=300", "sotester", "547", "300", "8", "#ffffff");

source being
preview.swf
change to svatebni/preview.swf (http://www.adelajizvecerela.cz/svatebni/preview.swf)

gore.m
07-09-2010, 08:29 AM
you have this line

var so = new SWFObject("preview.swf?keepSelected=t&selectedWindow=0&imageWidth=315&imageHeight=300&sWidth=547&sHeight=300", "sotester", "547", "300", "8", "#ffffff");
source being
preview.swf
change to svatebni/preview.swf (http://www.adelajizvecerela.cz/svatebni/preview.swf)


I have tried that, look at code I posted. I dont know why, but it doesnt work.
I think it shows swf (becauce I can see warning about player on place where player should be: "Pro zobrazení obsahu....")

There is an differnce between working and not working site. Working site (has all files in one folder) loads _.XML in "Live View" but not working site doesnt. :roll: (_.xml and swf are in same folder)