PDA

View Full Version : Persistent Bold Font in Dreamweaver


ally97
04-27-2010, 10:26 AM
Hi, I'm doing a simple website in Dreamweaver using tables, and no matter what I do I can't get rid of the boldness when viewed in a browser window, however looks fine when I am editing it. This is what I have :

</p>
<p><div align="left" class="no_bold">Text text text... </div>


This is what's in my styles which is a bit messy but I was trying anything haha:


<style type="text/css">
<!--
body {
background-color: #000000;
}
body,td,th {
color: #FFFFFF;
font-family: Arial, Helvetica, sans-serif;
font-weight:lighter;
}
.style1 {font-family: Arial, Helvetica, sans-serif;
font-weight:lighter;
th {font-weight: normal;}

th {
font-weight: normal;
}

.no_bold{font-weight: lighter;}
-->
</style>


I also checked the surrounding cells and they are all set to no style, I also tried using the no_bold style and the text stayed bold. Any help would be greatly appreciated.

Corrosive
04-27-2010, 12:21 PM
You sure none of your text is wrapped in <strong> tags?

ally97
04-27-2010, 01:07 PM
Yep, positive.

Corrosive
04-27-2010, 01:14 PM
Hmmm. There will be some CSS or browser defaults that are controlling your text styles. More likely browser defaults I'd say.

DWcourse
04-27-2010, 01:45 PM
Really, being able to see the page would help.

If you're using tables, table header cells <th> are bold by default.

Ricky55
04-28-2010, 12:21 AM
Have you tried just using font-weight: normal; rather than lighter on your .no_bold class?

If you're getting issues with browser defaults link to a browser reset file to zero them all out before hand.

http://meyerweb.com/eric/thoughts/2007/05/01/reset-reloaded/

ally97
04-29-2010, 02:15 PM
Ok, I quickly loaded this so you can see what it's doing.. here's a link to the page http://www.assignation.com.au/dfb.html

Also, although I've set up the link style it's still coming up as blue and underlined!! It's meant to be grey and not underlined. None of the styles are working and I don't know why.

ally97
04-29-2010, 02:19 PM
And I also tried that reset reload thing and it did not work. Also tried font-weight: normal.

tux
04-29-2010, 02:42 PM
Looking at your source code it looks like you have commented out your styles. Try removing <!-- and -->.

domedia
04-29-2010, 03:50 PM
It's a misconception. The text is not bold. :) Really.

The comment tags are supposed to be inside the <style> tags.

ally97
04-29-2010, 04:18 PM
No, that didn't work either. :(

DWcourse
04-29-2010, 04:53 PM
It's a misconception. The text is not bold. :) Really.

That's right. Try actually setting the font-weight to bold and you'll see the difference.

And you've also messed up the style definitions in your document:

.style1 {font-family: Arial, Helvetica, sans-serif;
font-weight:lighter;
th {font-weight: normal;}

You didn't close the .style1 rule so the rules below it (including .no_bold) are broken. The code should look like:

.style1 {font-family: Arial, Helvetica, sans-serif;
font-weight:lighter;}

th {font-weight: normal;}

Corrosive
04-29-2010, 04:53 PM
Agree with the lads. That text is not bold.