PDA

View Full Version : CS4 table issue


Hackit
04-26-2010, 09:07 PM
Hi everyone,

I have a perl script that counts the number of downloads, works great and i have no issue's with the code.

My problem comes when i open a page with my counter, cs4 does not follow the table size anymore and shows all the code on the page.

i have included a picture of before and after, it appears to me that each table has to sizes listed.

If some one can shed some light on this little problem I would be very grateful.


good
http://www.hackitz.ca/images/table2.PNG

bad
http://www.hackitz.ca/images/table.PNG

davidj
04-27-2010, 10:08 AM
Im guessing its because Dreamweaver doesn't process the PERL in design mode.

Does it break the script if you upload it and view it live

Hackit
04-27-2010, 03:07 PM
No the code is fine and works great no matter what view i use.

I think the issue has something to do with the width of the table, if you look at image one you can see that the main width is set to 430, and the other two sizes are 225 (211) and 226 (213)

on the bottom image you can see a big deiscrepentcey, as the sizes are 430 (1021), 225 (100) and 226 (915).

I think all I need to do is remove the size that is in brackets (1021), I just don't k now where this size is coming from as there are no css applied to the style of the table.

davidj
04-27-2010, 04:52 PM
Its the content which is pushing it wide I think

It looks like you are displaying some PERL comments in the <td

Hackit
05-19-2010, 03:56 AM
Ok I'm back at gtrying to fix this issue,

First here is the code:
-----------------------------------------------------------------
html code;
-------------------
<table width="430" border="0">
<tr>
<td width="215"><a href="/cgi-bin/counters/unicounter.pl?name=ufc.zip&amp;trackip=0&amp;deliver=http://www.hackitz.ca/Storage/ufc.zip">MC7 UFC Theme (Click here to download)</a></td>
<td width="215">
<b><span style="color:##5C8495">Downloads =
<!--#include virtual="/cgi-bin/counters/unicounter.pl?name=ufc.zip&write=ssi&inc=0&trackip=0"-->
</span></b></td>
</tr>
</table>
-----------------------------------------------------------------------
css:
---------------
/*================== downloads.html ==================*/
#page2 #content { padding-bottom:38px;}
#page2 #content .col_1 .indent { padding:24px 22px 0 30px;}
#page2 #content .col_1 .img_indent { margin:0 19px 23px 0;}
#page2 #content .col_1 h4 { padding-top:8px;}
#page2 #content .col_1 .line_hor { padding-bottom:29px;}
#page2 #content .col_1 .column1 { width:433px;}
#page2 #content .col_1 .column1 { position:relative; margin-left:-10px;}
#page2 #content .col_1 .column2 { width:433px;}
/*==============col-2============*/
#page2 #content .col_2 .indent { padding:24px 22px 0 30px;}
#page2 #content .col_2 .img_indent { margin:0 19px 23px 0;}
#page2 #content .col_2 h4 { padding-top:8px;}
#page2 #content .col_2 .line_hor { padding-bottom:29px;}
#page2 #content .col_2 .column1 { width:433px;}
#page2 #content .col_2 .column1 { position:relative; margin-left:-10px;}
#page2 #content .col_2 .column2 { width:433px;}
---------------------------------------------------------------------
screenshot of what it looks like in dreamweaver:
--------------
http://www.hackitz.ca/images/web%20images/dwpearl.jpg
--------------------------------------------------------------------

This still works on the web no issue's.

I'm not sure when it started to look like this in dreamweaver.
It just makes it hard to work with as I'm a visual person and still need to check the layout as i code.

I hope someone has come accross this before and has a fix.

DWcourse
05-19-2010, 04:45 AM
Unless you've set up a testing server Dreamweaver isn't going to process your scripts. So what it looks like in Dreamweaver doesn't matter. If it looks OK running on the server be happy.

Hackit
05-19-2010, 05:52 PM
Thank s for all the help everyone, I have fixed the issue, I moved from a cgi script to php.

I updated to the php code and now have a config page to edit the links.

Thanks again.