PDA

View Full Version : Database connection


Richard Diedrick
04-18-2010, 01:03 AM
I have set up WAMP server and all appears to be working correctly have created a connection that tests ok created a recordset that tests ok can priview the records in the database but when I preview the php page in either live view or with localhost browser I get the followin:
Warning: virtual() [function.virtual (http://localhost/BudsEquipment/Test%20Pages/function.virtual)]: Unable to include '/Connections/Equipment.php' - request execution failed in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 1

Notice: Undefined variable: database_Equipment in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 34

Notice: Undefined variable: Equipment in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 34

Warning: mysql_select_db() expects parameter 2 to be resource, null given in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 34

Notice: Undefined variable: Equipment in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 36

Warning: mysql_query() expects parameter 2 to be resource, null given in F:\wamp\www\BudsEquipment\Test Pages\Test.php on line 36
Need help??

mangofreak
04-18-2010, 06:38 PM
Did you upload to your wamp the Connections folder where Equipment.php should be?
What's the code in line 1, 34, 36

You need to provide more details

davidj
04-19-2010, 12:34 PM
it could be the connection include

/Connections/Equipment.php

omit the first /

Richard Diedrick
04-20-2010, 06:59 AM
Thanks for the replies. I really donot understand what is going on with my Dreamweaver installation and I am begining to think that may be the problem. I just re-opened Dreamweaver and turned on WAMP and previewed the page without changing anything and it now works?? I have a similar problem with standard html pages with logos and pics when I preview using live view the logos and pics are not there but if I upload to my actual site they work just fine. Makes checking my work hit and miss which is frustrating any experience with this?? Again thanks for the responses.