PDA

View Full Version : Flash Valley Newsticker problem linking xml file


spazzer
02-25-2010, 07:24 PM
Hi,
I have used the Flashvalley Newsticker and linked an XML file to it containing the items to display in it,in my website I was previewing in my browser through Dreamweaver and everything was fine but when I uploaded to server the Newsticker shows but there is no information in it !
I'm assuming its something to do with the link between the xml file and the swf file that is not in the same folder, should I place the swf file and the xml in the same folder or can someone explain how I link to it I have tried everything but no joy !!!!

if it helps my website is at eustonfishingclub.com (http://eustonfishingclub.com)

Thanks,
Nick Carter :grin:

gentleone
02-25-2010, 08:13 PM
Did you read the manual? This is what it says about the XML file:

The Flashvalley ticker component is populated via an XML file that can be sitting near the SWF that is using its data or it can be on another server as well.

You can enter the path to the XML file directly in the parameter panel or if you want to grab the path to that xml dynamically you can leave that field blank and use the loadNews method on the ticker, for example: myTicker.loadNews(xmlPath)


Did you download the provided Macromedia extension and edited the file in Flash or not?

spazzer
02-26-2010, 05:43 AM
Hi,
Thanks for reply, yes I did download the extension , I'm just struggling with what to put in the parameters panel to link to the file, I'm not particularly good at this and know its something really simple so bear with me please, my latestnews.xml file is in my websites folders under XML and my swf file is in my Images/Global folder I'm just not linking the two any suggestions as to what to type in the parameters box would be good I know you cant see my folder structure but can post that if it will help !

Thanks for help,
Nick C

gentleone
02-26-2010, 05:07 PM
Well... It's all described in the manual. Check your paths also.

spazzer
03-01-2010, 06:58 PM
Hi,
Thanks for reply again, I dont understand the loadNews method, I know what it says in the manual and please pardon my stupidity but I'm just not getting it, can explain, I have even moved my .xml file into the same folder as the swf file and then typed in my files name latestnews.xml but still no joy, it getting really annoying because I know its a simple thing I'm doing wrong, I dont understand the loadNews method can anyone explain further ????

Thanks for your patience !!!!