PDA

View Full Version : Help! I can't get a Flash file to work in DW.


rs1856
02-19-2010, 09:55 PM
Hi, I am trying to get a flash file (swf) to work in DW CS3 or CS4. I used the DW insert media option to add the flash file and follwed the prompts. the flash file placeholder shows on the page in DW, but will not "play" in DW when using the "play" option, nor will it show up when using the "preview in browser" option.

I have tried this in DW CS3 and CS4. I even uninstalled and re installed both.

The scripts folder, swf file, and html file are all in the DW default locations, all in the root folder, I haven't moved them.

here is the DW generated code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Untitled Document</title>
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
</head>

<body>
<p>test test test test </p>
<p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="30" id="FlashID" title="hawks">
<param name="movie" value="hawks1.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="7.0.70.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="hawks1.swf" width="800" height="30">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="7.0.70.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
</p>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</body>
</html>

Any help would be greatly appreciated, thank you.

DWcourse
02-19-2010, 10:49 PM
It looks good. Maybe someone else can see something.

Is the hawks1.swf in the same folder as the page it's on?

Also, I know sometimes IE won't play javascripts on local files so theat might prevent the Scripts/swfobject_modified.js file from running and playing the Flash.

rs1856
02-19-2010, 11:22 PM
Thank you for the reply. Yes, they are all in the root folder. Could it be something on my machine? I am so frustrated.

rs1856
02-20-2010, 04:43 AM
Nevermind! I got it. Being the newb I am in Flash, I used a ticker maker to produce the flash file, it was saving the xml file in my documents and the swf file on my desktop...I am good now, it works fine! Thank you.