PDA

View Full Version : Cannot save changes in template


ingak
02-11-2010, 05:01 PM
Hi there everyone. I am new her and have been trying to teach myself Dreamweaver over the last few months but now I really seem to have gotten myself in trouble and I would really appreciate any help I could get :-)

So the issue is that I wanted to ad in Google analystics and copied the given code above </Body>. When I wanted to save the site I go a msg telling me "You have placed a editable region inside a block tag" and that I should move the region outside the block tag.

I deleted the goggle code and fixed the problem but I still can't save the site. I really don't know what to do. Have been googling the problem all day but haven't found any remote problem.

I really would very much appreciate all help!

Thank you!

DWcourse
02-11-2010, 06:18 PM
What do you mean you "can't save the site?" Are you able to save the template?

ingak
02-11-2010, 06:47 PM
Hi there, thanks for you reply!

Yes, sorry I meant the template but not the site. I already have the site up and running but am doing some changes to it.

Whenever I make changes in the template and try to save it then tells me access is denied to the file and the file changes to a read-only file. I tried to save a new copy on my desktop and then replace the one in my root folder but I wasn't able to do that either.

I went into the properties of the file and it's not a read only file.

And I don't know if it matters but I am working on xp using CS4

DWcourse
02-11-2010, 07:01 PM
Could be a file ownership issue (any recent system updates). I don't work much on Windows but I've seen elsewhere that the process goes something like this to fix the issue:

In Windows right click on the (root) folder that contains the files, properties > click on the security tab, click on advanced > Owner tab > Edit.

Then click on "other Users" and find the administrators account for your computer or just your user account, check the box that says "replace owner on subcontainers and objects" (IMPORTANT) and hit OK.

That was for Vista should be something similar for XP

ingak
02-11-2010, 09:22 PM
Thanks for that but there doesn't seem to be any option like that in XP. You have a sharing option but only to make it private and I tick it but that made no difference.
I have also gone many times today into the properties of the folder and every time had to take the tick out of the read-only box.

There have not been any system updates. I had been working the whole day on the file and everything seemed all right and then I tried adding the Google code and save and that's where all the trouble began.

Could it be that the code is so screwed up that the program wont allow me to save it? Like I said I am not very experienced with it trying to read into the code is like trying to read Chinese,,well almost.

Could I possibly try to make a new root folder and copy all the folders and upload the site from there?

But thanks you so much for your help, I really appreciate it. Rather sad thinking that all the work I have done has now gone perhaps to waste.

DWcourse
02-12-2010, 02:37 AM
In Windows, right+click the file and choose Proprties. Then select the General tab and make sure "Read Only" is NOT checked. Don't know if there's a way to do it for a lot of files at once or not.

edbr
02-12-2010, 03:20 AM
i think you can highlight multiple files in windows ,right click properies read only, uncheck