PDA

View Full Version : gap in firefox


cars111
02-05-2010, 05:17 PM
hi guys ive designed a webpage in photoshop and importedinto dreamwaever, i ahve imported a flash movie the same size as the middle section of the webpage, when i preview in exploreer and opera looks great when i do this in firefox there is a gap at the bottom of the flash movie, what do i need to do to get rid of it thanks

<html>
<head>
<title>HIW PART 1 empty whiteboard</title>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<style type="text/css">
<!--
body {
background-color: #06F;
}
body {
text-align: center;
}
#Master {
width: 990px;
margin-top: 0px;
margin-right: auto;
margin-bottom: 0px;
margin-left: auto;
position: relative;
left: 0px;
top: 20px;
}
-->
</style>
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
</head>
<body leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<div id="Master">





<!-- Save for Web Slices (HIW PART 1 empty whiteboard) -->
<table id="Table_01" width="900" height="960" border="0" cellpadding="0" cellspacing="0">
<tr>
<td colspan="8">
<img src="images/how_it_works_01.jpg" width="900" height="181" alt=""></td>
</tr>
<tr>
<td>
<img src="images/how_it_works_02.jpg" width="95" height="77" alt=""></td>
<td>
<img src="images/how_it_works_03.jpg" width="83" height="77" alt=""></td>
<td>
<img src="images/how_it_works_04.jpg" width="99" height="77" alt=""></td>
<td>
<img src="images/how_it_works_05.jpg" width="138" height="77" alt=""></td>
<td>
<img src="images/how_it_works_06.jpg" width="107" height="77" alt=""></td>
<td>
<img src="images/how_it_works_07.jpg" width="116" height="77" alt=""></td>
<td>
<img src="images/how_it_works_08.jpg" width="168" height="77" alt=""></td>
<td>
<img src="images/how_it_works_09.jpg" width="94" height="77" alt=""></td>
</tr>
<tr>
<td colspan="8"><div>
<div>
<object id="FlashID" classid="clsidhttp://codingforums.com/images/smilies/biggrin.gif27CDB6E-AE6D-11cf-96B8-444553540000" width="900" height="465">
<param name="movie" value="images for flash+++dont upload/Untitled-1.swf">
<param name="quality" value="high">
<param name="wmode" value="opaque">
<param name="swfversion" value="6.0.65.0">
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf">
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="images for flash+++dont upload/Untitled-1.swf" width="900" height="465">
<!--<![endif]-->
<param name="quality" value="high">
<param name="wmode" value="opaque">
<param name="swfversion" value="6.0.65.0">
<param name="expressinstall" value="Scripts/expressInstall.swf">
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
</div>
</div></td>
</tr>
<tr>
<td colspan="8">
<img src="images/how_it_works_11.jpg" width="900" height="237" alt=""></td>
</tr>
</table>
<!-- End Save for Web Slices -->
</div>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</body>
</html>

gentleone
02-05-2010, 05:41 PM
by getting rid of the 'slice and dice' with Photoshop.

http://www.dreamweaverclub.com/forum/showthread.php?p=173344#post173344

domedia
02-05-2010, 07:26 PM
It might be the use of tables and no doctype. Will adding a 4.01 strict doctype fix it?