PDA

View Full Version : Problem connecting Dreamweaver CS3 with MySQL Database


Jakkals
01-25-2010, 09:41 AM
Good day

I've seen a previous thread in DWC and it didn't helped me much. My problem is at the moment that I get an error when I try to make a database connection. The error I get is:

HTTP Error Code 404 File Not Found. Here are some possible reasons for the problem:

1) There is no testing server running on the server machine.
2) The testing server specified for this site does not map to the http://localhost/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL Prefix maps to the root of the site.

Information you might need to help me with the problem:

OS: Windows XP Professional - SP2
TESTING SERVER: Wamp Server 2 (Apache 2.2.11 | PHP 5.3.0 | MySQL 5.1.36)
DREAMWEAVER: Version CS3

My "HTTP Address" and my "URL Prefix" in Dreamweaver Site Management is "http://localhost/"

I'm using SQLYog Enterprise to create databases and can sucessfully connect and create databases. In my WAMP Server's "phpMyAdmin" window I can see the database that I created.

When I try to connect to a database in Dreamweaver I use the undermentioned settings. Please note that the MySQL server, User name and password is the same as SQLYog which connects successfully:

Connection Name: myconnectionname (Please Note: I'm not using "localhost" or something that might clash with the server but a unique name)
MySQL server: localhost
User name: root
Password: mypassword

I've deleted the "_mmServerScripts" folder in my website's root folder but still I can not connect. It seems to me all my settings is correct :confused:. I've uninstalled Wamp and installed it again but with no luck.

Please help! :(

Jakkals
01-25-2010, 10:34 AM
I've solved the problem on my own. The main problem here lies in:
"2) The testing server specified for this site does not map to the http://localhost/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL Prefix maps to the root of the site." part of the error code.

I've seen that the connection to the _mmServerScripts folder is incorrect and I've changed my settings in "SITE DEFENITIONS" in DreamWeaver CS3.

My "HTTP Address" in "Local Info" as well as my "URL prefix" in my "Testing Server" windows has been changed to "http://localhost/mysite/".

Now the "http://localhost/_mmServerScripts/MMHTTPDB.php" connection string has been changed to "http://localhost/mysite/_mmServerScripts/MMHTTPDB.php (http://localhost/_mmServerScripts/MMHTTPDB.php)" and DWCS3 and WAMP can connect to each other.

bxpurce
03-02-2011, 12:38 PM
Jakkals
Couple of questions:
1. do you see your _mmServerScripts folder when using DW?
2. I have a public_html and a www folder. I have ftped the folder to the root and these two folders

I have also tried changed my conn strings to Localhost\mysite still no go. do you have any ideas

thanks
B

adimat
11-07-2011, 03:52 PM
I am using DW CS3 and continue facing this problem when try to connect with my database, I have read a lot of forum on how to solve "error 404" when try to connect but everything seem hopeless.

Anyhow, I did try one thing, I copy the whole folder of "_mmServerScript" from other pc and copy it to root folder of mine, finally the problem above solved. I am now can connect my database with Dreamweaver CS3.

It seem that DW CS3 cannot create "_mmServerScript" when using this PC. Don't know why... Why not give it a try for you.