PDA

View Full Version : Internet Explorer Issues


Vinx21
01-22-2010, 08:39 PM
Hi,

I've got a site up at the address www.zerorelevance.com (http://www.zerorelevance.com). The site looks and works fine in Firefox and Safari but when its opened in iExplore everything is messed up. I've run several browser capability checks in dreamweaver that show no problems. Please any help anyone can offer is greatly appreciated. Thanks

edbr
01-23-2010, 12:55 AM
didnt look to but these errors came up when I checked
Result: 0 errors / 8 warnings

line 62 column 164 - Warning: inserting implicit <p>
line 67 column 127 - Warning: discarding unexpected </param>
line 67 column 182 - Warning: discarding unexpected </param>
line 67 column 231 - Warning: discarding unexpected </param>
line 67 column 490 - Warning: discarding unexpected </param>
line 67 column 499 - Warning: <embed> is not approved by W3C
line 76 column 52 - Warning: <img> proprietary attribute value "absmiddle"
line 62 column 164 - Warning: trimming empty <p>
Info: Doctype given is "-//W3C//DTD XHTML 1.0 Transitional//EN"
Info: Document content looks like HTML Proprietary

also some of these links point s to files on your computer not the server. Id get shot of the table too

<table border="0" cellpadding="0" cellspacing="5">
<tr>
<td><img src="BtnBack.PNG" alt="BackBtn" width="75" height="29" /></td>
<td><img src="file:///C|/Users/Student/Desktop/DP_Website/navabar-divider.png" width="5" height="38" /></td>
<td><img src="BtnFirst.PNG" alt="FirstBtn" width="75" height="29" /></td>
<td><img src="file:///C|/Users/Student/Desktop/DP_Website/navabar-divider.png" alt="" width="5" height="38" /></td>
<td><img src="BtnHome.PNG" alt="HomeBtn" width="75" height="29" /></td>
<td><img src="file:///C|/Users/Student/Desktop/DP_Website/navabar-divider.png" alt="" width="5" height="38" /></td>
<td><img src="BtnInfo.PNG" alt="InfoBtn" width="64" height="29" /></td>
<td><img src="file:///C|/Users/Student/Desktop/DP_Website/navabar-divider.png" alt="" width="5" height="38" /></td>
<td><img src="BtnNext.PNG" alt="NextBtn" width="75" height="29" /></td>
</tr>
</table>

Vinx21
01-27-2010, 04:48 AM
Think i've fixed most of the problems except forline 67 column 127 - Warning: discarding unexpected </param>
the embedded music player. Can anyone elaborate on this error more? Could the problem perhaps be something in the embedded player code? Thanks again

Vinx21
01-27-2010, 04:53 AM
I've actually tested the site with the embedded player completely removed and the same results still happens. please help. Thanks

edbr
01-27-2010, 05:54 AM
try changing
<style type="text/css">
/* place css fixes for all versions of IE in this conditional comment */
.twoColElsRtHdr #sidebar1 { padding-top: 30px; }
.twoColElsRtHdr #mainContent { zoom: 1; padding-top: 15px; }
/* the above proprietary zoom property gives IE the hasLayout it needs to avoid several bugs */
</style>
<![endif]-->

for this will give the conditional style for ie that i think it should have
<style type="text/css">
/* place css fixes for all versions of IE in this conditional comment */
<!--[if IE]>

.twoColElsRtHdr #sidebar1 { padding-top: 30px; }
.twoColElsRtHdr #mainContent { zoom: 1; padding-top: 15px; }
/* the above proprietary zoom property gives IE the hasLayout it needs to avoid several bugs */
</style>
<![endif]-->

Vinx21
01-28-2010, 12:47 AM
Unfortunately the issue wasn't resolved. I placed the new code in exactly and all that came up was single black line at the top of the page with elements of my css written in it. This was happening in both firefox and iepxlorer while the other mis alignment issues still persist in iexplorer.

Thanks for all the help with this issue so far. Any other advice or possible sources of information or help i could follow would be greatly appreciated.

domedia
01-28-2010, 03:24 PM
Cross browser compatibility requires two things, knowledge of the different browsers and knowledge about front end coding, HTML/CSS/JS. If you want to create web pages there really is no shortcut around this.

Vinx21
01-28-2010, 06:27 PM
Once again thanks for the help. I'm definitely starting to learn that there is for some reason a great different between iExplorer and regular browsers. I now also understand that there is generally no quick fix for this type of problem and is usually site specific.

If anyone has any information on sources of information focusing specifically on this type of display problem in iExplorer please let me know, or at least point me in a direction of a site or person that would possibly be able to help. Thanks again.

Vinx21
02-01-2010, 03:12 PM
bump

Still looking for any direction or help regarding making sites work in Iexplorer. Any forums or sites that offer specific knowledge or snippets would be greatly appreciated. Thanks