PDA

View Full Version : Template Issue - No Update Pages box when saving


keastie
01-11-2010, 02:50 PM
Hi Guys,

I have created my site using a template, and up until today it worked fine. I updated the template to give it a christmassy feel, changing he background and the header image but now when I'm going to change it back its allowing me to save the Template but it doesnt come up with the Dialog box regarding saving other pages. Any help would be appreciated!

George

DWcourse
01-11-2010, 03:10 PM
Did the changes occur in the actual file or were they in an external style sheet? Updating an external style sheet (or updating an image without changing the file name) doesn't change the template. All you'd need to do is upload the changed files.

Did you do a "Save As…" on the template at any point (i.e. change it's file name)? That would break the connection between pages and the template.

Otherwise:

Restart Dreamweaver
Check your site definition to make sure it hasn't changed
Make sure you didn't accidentally rename the Templates folder

keastie
01-11-2010, 03:17 PM
The changes are in the actual file,

No "Save As" has been done, the file is still called Template.dwt

I can open the index.html which feeds from the Template.dwt, when prompted I can open Template.dwt from it, but the 2 do not correspond in the way they look (Index.html is still christmassy)

I can go to Save As and overwrite the file, making sure it is saving as Template.dwt, and still nothing comes up.

DWcourse
01-11-2010, 06:37 PM
is the site online somewhere?

keastie
01-13-2010, 08:01 AM
Yes, http://www.newquay-jnr.cornwall.sch.uk

edbr
01-13-2010, 08:34 AM
you vave doctype twice btw delete lines 5 and 6

keastie
01-18-2010, 03:00 PM
Will this stop it working?

d a v e
01-18-2010, 03:09 PM
take one out and see ;)

keastie
01-18-2010, 03:21 PM
Haha! first job for tomorrow, benifits of working in a school; I get to leave at 4.30!

keastie
01-19-2010, 12:24 PM
Deleted it, still no update box

keastie
01-19-2010, 12:29 PM
Here is the coding for the site if this helps?!

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="stylesheet" type="text/css" href="ddsmoothmenu.css" />
<link rel="stylesheet" type="text/css" href="ddsmoothmenu-v.css" />

<script type="text/javascript" src="

keastie
01-19-2010, 12:33 PM
Well that didnt work....any way I can post it up?

Could this be more a problem with dreamweaver than it is with the template?

keastie
01-19-2010, 12:58 PM
Is there a possibility that the Template has been disassociated(?!) with the site?

Corrosive
01-19-2010, 01:13 PM
Is there a possibility that the Template has been disassociated(?!) with the site?

Yes, you could be right. Have you tried attaching it again?

keastie
01-19-2010, 01:14 PM
Ok Guys, thanks for your help. For some reason it wasnt seing the site folder. So just created a new site folder and its now working.

Thanks for your suggestions.