PDA

View Full Version : Saving templates


niksie
11-07-2009, 12:16 PM
HI there. I just installed Dreamweaver MX 2004 onto my pc which runs Vista. (previously I was running Windows XP).

I create my site in wwwroot, save all files and images etc to the root folder in the site name. When I now create a template for my site in dreamweave, it saves it outside the root folder, and no pages created from the template will update the images. I have defined the default images as well as root folder when I define the site in Dreamweaver.
I never had this problem when I used XP, is this a Vista/Dreamweaver problem or am I not doing something right?

Thanks

d a v e
11-07-2009, 12:25 PM
are the images within a locked region of the template? if not they won't update when you change and save the template page

niksie
11-07-2009, 12:31 PM
hi

yes, they are.

DWcourse
11-07-2009, 02:24 PM
Check your site definition. Dreamweaver has a problem with some version of Windows in that when you select a folder in the site definition, it actually selects the parent folder (not the one you chose). Here's some details: http://dwcourse.com/dreamweaver/windows-bug-local-root-folder.php

niksie
11-07-2009, 05:55 PM
thanks very much DWcourse...I will check that out and report back :)

niksie
11-07-2009, 07:54 PM
thanks, that worked...but now it seems as if the style sheet isn't linking. do you perhaps have a fix for that? i'm thinking maybe i should just go back to XP as i never had these problems then LOL

niksie
11-07-2009, 08:06 PM
ok...i got it sorted out...i put href="../styles/stylesheet.css" instead of just href="styles/stylesheet.css" This seemed to sort the problem...

DWcourse
11-07-2009, 08:08 PM
Right, if your site definition was messed up, then your links probably were as well.