PDA

View Full Version : What is wrong here in Firefox?


darwin
11-01-2009, 06:11 AM
I am designing a small website for a local nature group, all looking great when using Dreamweaver CS3-including the previews in IE8 and Firefox 3.

If I go the correct web address :

http://tlcuk.awardspace.co.uk/index.html

everything works as it should in IE8-but not too good in Firefox.

I have looked at everything-can someone tell me what is missing-the root and remote folders are identical.

Thanks and here's hoping.....

Corrosive
11-01-2009, 10:03 AM
This is the link to your stylesheet...

file:///C|/Documents and Settings/Tony Hall/My Documents/TLNG/innovation/innovation/innovation/default.css

It is pointing to a file on your hard drive. So, when you see it in preview it is ok but when viewers try it online they get the problem because they have no access to your hard drive.

You must define your website correctly when you start and stuff like this won't happen.

Try this...

http://www.dreamweaverclub.com/define-your-site.php

darwin
11-01-2009, 11:19 AM
I set up the site locally first and then 'got' the webspace-is this the problem?

tlcuk.awardspace.co.uk/innovation/innovation/innovation/default.css is where the styleshhet is, how do I point to that instead of my local hard drive?

Corrosive
11-01-2009, 11:45 AM
I don't know how you ended up where you are. Only you can answer that...

http://webdesign.about.com/od/css/f/blcssfaqlinkext.htm

darwin
11-01-2009, 05:41 PM
I think its beacsue I set up the Manage sites and didnt change from 'document' to site root perhaps.
I think I will start over again.....

DWcourse
11-01-2009, 07:30 PM
I think its beacsue I set up the Manage sites and didnt change from 'document' to site root perhaps.
I think I will start over again.....

No that's not it. Both links relative to document or site root are valid.

I'd make sure that your local site is pointing to the correct folder and that the files you're linking to are somewhere within your local root folder.

darwin
11-02-2009, 07:28 AM
Probably a few mistakes on my behalf, best thing to do was start again and I did.

Working fine so far, just waiting for input from the group for content now.

In case any of you are interested-this is what it looks like so far:

http://tlcuk.awardspace.co.uk/

Thanks for all those who took their time to help-really appreciated.

Corrosive
11-02-2009, 07:48 AM
That looks better :)

Ricky55
11-03-2009, 06:34 PM
That owl looks a bit crap.

d a v e
11-04-2009, 03:13 AM
and if you underline your headings they look like links ;)